community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

How to make multiple tables appear in one tab in Excel after applying Group By

Meteoroid

I'm very new to Alteryx.

 

I grouped my data by name.

After I selected Group By from the Table tool and I used the Render tool to export it to Excel file, each group of data was split in separate tabs.

 

Is there anyway to make them appear in one tab?

 

Example: these 2 tables appear in the same tab in Excel sheet with headers for each group and some space between each table.

 

NameTypeMonth 1Month 2Month 3Month 4Month 5Month 6Month 71 MONT Diff %
ABACDe2,9892,3241,3008,1582,1251,1261,12510%
ABACSu6,2584,1225,1255,5881,1254,2562,12530%

 

 

NameTypeMonth 1Month 2Month 3Month 4Month 5Month 6Month 71 MONT Diff %
UPECDe1,0002,0001,0007,1361,1251,6581,458100%
UPECSu5001,1255,1474,3696,4782,1456,125100%

 


Thank you.

Alteryx
Alteryx

Hi @panupong,

 

This is likely to be happening because of the configuration in your output tool and how you are outputting this. If the data is coming in as one table, the default settings for an export should be for it to all appear on one tab. See this article on the output tool which should help - https://community.alteryx.com/t5/Alteryx-Knowledge-Base/Tool-Mastery-Output-Data/ta-p/30023 or in the help documentation https://help.alteryx.com/2018.2/DbFileOutput.htm

 

Let me know if this helps

 

Regards

Will

Meteoroid

Thank you so much.

I really appreciate it.

 

I will read the document and see if I can work around with that.

 

Thank you again,

Panu

Magnetar
Magnetar

Hi @panupong 

 

A workaround of sorts that will still require a bit of cleanup in Excel.

 

You can insert one or more extra columns (I called mine "Hold" in the attached example) into the original data.

 

Then, after the table tool creates records per your grouping, use the Layout tool to combine them horizontally together.

 

image.png

 

After you render to an Excel table, open the file and remove all of the extra columns to hold the space.

 

Please let me know if that works for you.

 

Cheers!

Esther

Meteoroid

Thank you so much!

I'm going to try it.

Labels