Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Help needed: unable to connect to Salesforce input

I'm using the trial of Alteryx to see whether it can be useful within our company, and the first thing we want to test is whether it can link to Salesforce.


When I try to configure the input it does not connect, and there is no error message explaining why.

- There is a thin pink bar underneath the 'connect' button which suggests that it wants to detail an error but it doesn't (this is where errors have have been detailed previously when I've tried messing with the URL input as a test)

- The password and security token have been reset for this exercise. I can access the account through Salesforce, but not via Alteryx

- The Salesforce account has system admin rights, and the API is enabled

- The URL I'm trying to connect to is

- The version of Alteryx I'm using is a trial downloaded last week (v11.0.3.25674)


Does anyone have any experience with this kind of error that can offer some advice? Not sure if I'm missing something simple here.


Appreciate any help that may be available.




I am having this exact same issue.  I tried changing the LAN settings and Alteryx User settings as discussed in other posts.  No success.  Has this been solved?

I have been working with the Alteryx team and learned that they don't support Lightning, only Classic.

They have not seen enough demand yet to develop a Lightning connector -- can we make this an official request, or is a new thread required?

how much demand is required to develop a lightning connector?  i just hit a dead brick wall because there is not lightning connector.  I'm back to stone age SF data loader?


I have actually since been able to connect by adjusting the URL I used. It seems natural to use, but that doesn't work. When you enter your address in a web browser you will see that after you connect it is converted to a (similar to a Classic URL). THAT is the URL you want to use. Unfortunately this means that you will still have to update all of your connections whenever your environment is updated/refreshed, but at least it does connect.

thanks i'll try that


@BrianPrep @dynamicsnail @peterblake @cthompson


If dynamicsnail's suggestion doesn't work for you, you should outline what you'd like to see on the Ideas page.  That's where Development looks to evaluate customer demand.  In fact, they value end user comments so much that it will get much more attention if one of you submits the idea than if I did.  (Be sure to all go star that idea post after you write it!)