Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

[Help] Error Encountered: An item with the same key has already been added


I have a SharePoint online list I'm trying to connect to.  Every time I try making the connection, no matter if its a new workflow or an existing workflow, I get this same 'item with same key' error.


Anyone with the same issue found a solution?


For reference; this is a SharePoint list and I've successfully connected to many other lists on the same location. 


Hi Shap,


Thanking you for posting your question on the Community forum. Can you please share screenshots of your workflow, the error once it's created and the Sharepoint List Input tool configuration?





John Posada

Senior Customer Support Engineer


John Posada
Cloud Engineer

did the error resolve? I am facing exact same issue. I have connected to multiple lists on same sharepoint site. But some lists give me below error -

SharePoint List Input (4) Error encountered: An item with the same key has already been added.

When I connect to same list using a web browser - it works fine. 




We are facing the exact same issue. It would be nice if someone from Alteryx could give us some solution, as the error is so uninformative.


Best regards, 

Was curious if this issue was ever resolved?

I am receiving the same error. 

I am reading from the Sharepoint (via the Sharepoint List Input tool), modifying some data through the workflow and trying to post back to the same Sharepoint list with updated data. 

But it is giving me the error : "Error Encountered: An item with the same key has already been added."

On the configuration of the Sharepoint List Ouput, I have the Ouput Options as "Update; Warn on Update failure" with all the same connection information there. 

I initially thought it might be an issue of it being a sharepoint library vs list issue but I am able to read in the data but unable to post back anything. 



Was this issue ever resolved? Experiencing the same error

i am also facing this same error.. whether it is resolved, please post the solution to rectify this error.




Just checking if there has been a fix to this issue. I am trying to write to an empty list and I've made sure that the data types match, but the issue persists. 


Any advice / tips would be greatly appreciated!





Hi @JohnPo,


Please see my screenshot below. Any help you could provide would be much appreciated. 



Alteryx SharePoint List error.png



Hi - Has this ever been resolved, I am experiencing the same issue.