Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Have a gallery app which does not prompt for an excel sheet name

Alteryx Partner

Hi All,


I have an app that reads in two Excel xlsm files does some Alteryx magic and overwrites a sheet (Drop) in another.


The files are of a standard format so the two input files will have a sheet named "Data", and the output file I'm writing to has a sheet "ComboData".


My app prompts the user for the file name and I used:


 File Browse Tool :Arbitrary FIle Spec *.xlsm 


Action tool: Update Value  - for the  File value.

                   In replace a specific string I replace the entire file name (leaving the |'Data' )


This works fine when I run it locally - no prompt for a sheet name on input or output, but when published to the gallery it prompts for table/sheet name.


Is there a way to have it not prompt for a sheet name in the gallery?




Alteryx Certified Partner
Alteryx Certified Partner



I'd use a Folder Browse tool instead of a File Browse tool.  Then I'd use a text box to ask for a filename.  Using ACTIONS, I'd update the directory and the filename and take control of the sheetnames in my workflow.


The gallery won't prompt this way.






Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Alteryx Partner

This has been determined to be a bug. Apps should behave the same way whether run locally or on the gallery.



Hi Bob


Did you get any further info with regard to a fix for this bug? I'm still getting the same experience, where in the Gallery I'm always prompted to select a worksheet name when using an Action tool to load from an Excel file.




Alteryx Partner


I talked with someone? back then at Alteryx and they said it was a bug and would be resolved in a future release. I guess not yet.


I'll post it as a bug in the Ideas section.






As of January 2019, still not fixed.  @Bob_Blackey if you'll post a link to your bug post in the Ideas section I'll star it or like it or whatever.


Any update on this bug? It's giving me some major headaches that I don't want to have to code around if possible.


Found a few other community articles asking about this and seems like nothing will be fixed for a while, so I had to code into my action tool and tell my end user to just select any sheet. The formula I used is below