Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Google Sheets Output Error

jtwmoore
8 - Asteroid

Hello All,

 

I have a workflow that pulls data from a Google Sheet, transforms it, and then outputs it to a different Google Sheet. The workflow was running with no errors for weeks, but now it is throwing an error and not exporting all the data. The data set is only about 20,000 records and I have a few other nearly identical workflows with smaller data sets (5,000-10,000 records) that run fine. From what I can tell looking at Workflow Messages, it splits the output into chunks or "payloads" and exports them in sequence. When I get this error, one or more of the payloads don't make it through and the corresponding rows in the Sheet will be empty, leaving large "gaps" in the data. Here is a screenshot of those messages:

 

GoogleOutputError - WorkflowMessages.PNG

 

 

 

 

 

 

In this case, it looks like payload 4 didn't make it.

 

Here is the error message in full:

 

Error: Google Sheets Output (68): Tool #402: Error trying to publish workbook: HTTP/1.1 302 Moved Temporarily
Content-Type: application/binary; charset=ISO-8859-1
Location: https://spreadsheets.google.com/feeds/cells/1RgWpl3av8l6EzKztc5UvYdQZCRDE5XudUmQpTWJFLK8/od6/private...
Date: Wed, 20 Feb 2019 00:05:50 GMT
Transfer-Encoding: chunked
Alt-Svc: quic=":443"; ma=2592000; v="44,43,39"

HTTP/1.1 400 Bad Request
Content-Type: text/html; charset=UTF-8
X-Robots-Tag: noindex, nofollow, nosnippet
Content-Encoding: gzip
x-chromium-appcache-fallback-override: disallow-fallback
P3P: CP="This is not a P3P policy! See g.co/p3phelp for more info."
P3P: CP="This is not a P3P policy! See g.co/p3phelp for more info."
Date: Wed, 20 Feb 2019 00:06:52 GMT
Expires: Wed, 20 Feb 2019 00:06:52 GMT
Cache-Control: private, max-age=0
X-Content-Type-Options: nosniff
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
Server: GSE
Set-Cookie: NID=160=RwJSLKzpSYKymkG7iieFBC-gBf-Jn4TBa5XQtVSVtnbhk_i1XM_BMziWfcceKNlosXYPx3Q5a2hZNyPe3noufdN7j5PqReMmdib7Fmo9HqcSPRo_qQmE1v8Ek5-0ifZ980zC7ex_oho3e9Vtnrxq1o9xsg-6QKmbtTjt7kJKt2c;Domain=.google.com;Path=/;Expires=Thu, 22-Aug-2019 00:06:52 GMT;HttpOnly
Set-Cookie: NID=160=PJy9Fq_aRRpxJ1l27kAYK_OuievSJJqJFCtDI_AFF2BfAPwtImJEJajthSTnLlU7PwI8MouZ0yXi7Ie7C4AlfQjYGLoT1ilktF99FOz0MHC6PNKFsA5xNbvC4Z3pLal26VkDTHUTxajeRoNGgJZyZwGoDdnaYbuKXJOVUv3yf7w;Domain=.google.com;Path=/;Expires=Thu, 22-Aug-2019 00:06:52 GMT;HttpOnly
Alt-Svc: quic=":443"; ma=2592000; v="44,43,39"
Transfer-Encoding: chunked

 

All my research on this issue has turned up nothing. I somehow doubt it's purely a record count issue since I can't be the only person trying to output more than 20k rows to Sheets. I also confirmed that it's not a Sheets limitation issue as I'm nowhere near the 2 million cell limit. I'm hoping there's a simple solution out there, but if not, my backup solution is to implement the setup detailed here into my workflow so that the output tool isn't exporting all 20k at once. Still, seems silly that the tool can't handle a measly 20k records. Am I missing something?

13 REPLIES 13
mbraswell
5 - Atom

I am having the same error and I think have traced it to the sheet being protected.  I thought the google sign in was passed to the sheet with the output tool package but probably not.  I unprotected the sheet and didn't have the error.  

I hope someone can help with this soon.

soncoku
9 - Comet

hey @jtwmoore 

I had the same error today when I tired reading data from a google sheet and I fixed it by duplicating the sheet and renaming it to something simple (Input Data)

Julien_B
8 - Asteroid

I have the same issue with 2021.1
Any of you have found a workaround ?

Julien_B
8 - Asteroid

I've just downloaded again the Google Sheet Tools installer and reinstalled the package (without uninstalling the previous version).
The same workflow is now working.
Don't ask me why...

 

 

Labels