community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Gets Message "There Were No Output Files" in the App Results

Meteoroid

Hi,

 

I am relatively new to Alteryx. I tried to create a simple Analytic App with a File Browse Tool-->Action Tool-->Input Data Tool-->Browse Tool. But every time when I click "Finish" after selecting a Excel File and worksheet it will out a message "There Were No Output Files" in the App Results window.

 

File Browse Tool -- I selected the "Standard Database File Formats" option

Action Tool -- I selected the "Update Input Data Tool (Default)" option

 

I am not sure what I did wrong. I tried looking at it and searching through the forum with no avail.

 

Thank you in advance.

Alteryx Certified Partner
Alteryx Certified Partner

Alteryx Apps are designed to present users with a very specific output, they aren't a development tool; thus when you are developing an Alteryx application you must have some sort of output (and a browse does not count as an output).

 

You would need to use an 'output data' tool to write your datastream to a file; when you have done this and you run your app, this file will then be presented for the user to open.

 

Ben

Meteoroid

Thank you Ben. This helps.

Atom

Try this: Go to

Menu View > Interface Designer Ctrl + Alt + I 

On Success - Show Results to User > Open files From These Tools > ☑ (Click checkbox)

Meteor

Thanks it worked fine.

I think there is an example app in the Academy (Using Analytic Applications) where a work flow was converted to an App. This workflow has a Browse Tool on the output.  

clipboard_image_0.png

 

 

The results are displayed to the user as shown below:

clipboard_image_1.png

How can I make an App to display result in a window as demonstrated in Interactive Lessons?

 

Labels