community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

GZIP support not working in 2018.2 Input tool

Comet

It was my understanding from the discussion at https://community.alteryx.com/t5/Alteryx-Designer-Ideas/Support-for-GZIP-gz-compressed-files-in-inpu..., that GZIP files were going to be supported in the Input tool in version 2018.2. I finally got upgraded to 2018.2 this morning and was eager to try it. I was disappointed to received the error, "Error extracting file: Unable to read file metadata."

 

I tried to attach an example file, and got the error:

  • The file c3643_emf.access.log-20170708.gz does not have a valid extension for an attachment and has been removed. 7z,alc,are,bmp,csv,cylc,dbf,doc,docx,gpx,gzlc,ics,pdf,ppt,pptx,qvd,qvw,qvx,rtf,slc,srclc,tbm,tde,tds,tdsx,tms,tps,twb,twbx,txt,xls,xlsx,xml,yxdb,yxft,yxi,yxlc,yxmc,yxmd,yxwz,yxzp,yzwz,yzxp are the valid extensions.

 

So, I compressed it using 7-Zip into a .7z file and attached it. It is from a test (not containing any sensitive information) we ran last year, and extracts fine using 7-Zip. You will need to extract from the extract.

 

I was also surprised to see that the file does not even show up in the "all data files" list, nor when selecting GZip. I believe this may be due to the specification as "*.tar.gz" rather than just "*.gz".

 

I believe this would be a great feature... if it worked...

 

Asteroid

As replied by @DanM currently, only tar.gz is supported.

If you have tar.gz file, you can find it with "all files", less convenient, but still not bad.

 

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/gzip-tool-unable-to-read-file-meta-dat...

Labels