community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Formula Tool returning numeric string values

Hi All,

 

I have an issue with the formula tool with a very simple IF statement updating values of an existing field:

 

 IF [Category]='Category W' THEN [Channel] = 'Other' ELSE [Channel] ENDIF

 

The IF statement above is intended to replace all 'Category W' with 'Other' in the 'Channel' field, yet it is returning integer vales (of Zero) as a string. Has anyone seen this? or know how I can fix it? 

 

Thanks

Clementine

Update: Have now solved this, the statement should have been:

 

IF [Category]='Category W' THEN 'Other' ELSE [Channel] ENDIF

 

Thanks to the following post: 

 

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Formula-Tool-Returning-0-or-1-instead-...

Alteryx Certified Partner

Glad you solved it, 

 

I see this a lot in formulas that user will write If qThen x=y Else z ENDIF

 

When using x=y after then you are create a true/false statement (0 being false)

Labels