Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Register for the upcoming Live Community Q&A Session - and don't forget to submit your questions for @DeanS regarding the future role of analytics here.

Find & Replace Tool - Replace Drop-Down does not Display Value Option

8 - Asteroid



This is my first time experimenting with the Find & Replace tool. I have a simple lookup list setup in an XLSX document that I am pulling in via a Text Input tool into the R Input connector of the Find and Replace tool. Based on everything I am reading, I should be seeing a list of the two columns (named "Find" and "Replace") that I have setup in my lookup list. It is not showing up in the list. I tried removing all tools and starting over. I created a new workflow. I pulled in Input Tools instead of Text Inputs. So far nothing has worked. If you look at the screenshot you can see that Alteryx understands that I have a second column since it lists "Replace" as an option for appending which is not what I want.


Please help.




Alteryx Certified Partner
Alteryx Certified Partner

Find Replace only works with string data types....




Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
8 - Asteroid

That would explain it. :) 

Thank you!