Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Check out our powerful new search update! You can read more here. Please let us know if you have any feedback by creating a topic here.
SOLVED

Field Summary tool temp file persistent error

Highlighted

Haha, DOS was so very unforgiving

 

My global workspace is C:\ProgramData\Alteryx

 

I get the same error when I run the macro on its own

Error: Run Command (105): File not found "D:\Alteryx Temp Directory\Engine_7872_6b1eeb13c6c240b1ab64d2512c5d5aa3_\__temppath__.txt"

 

I may give client services a buzz on this one and then come back and let you all know what they figure out.

 

Thank you both, simon and s_pichaipillai for trying to help!

Highlighted
Bolide

Last thought, do you have user settings (default temp dir) enabled? they'll override your system settings. good luck :)

Highlighted
Great thought but alas I do not have that enabled!
Highlighted

@david_fetters

i did some testing by changing the Engine path in System Settings "C:\ProgramData\Alteryx\Engine" to some other path 

Now "IFS.yxmc" macro has failed

Then what i did was, i changed the temp path (override system setting) in Designer to "C:\ProgramData\Alteryx\Engine"

Now it has succeeded 

 

So definitely it’s an issue with the run command tool inside IFS macro which is not recolonizing the path other than global engine path

copying 

@Ned@TaraM@AdamR  FYA

 

Highlighted
Creative Director
Creative Director

@s_pichaipillai - thanks for tagging me. This is being looked at by our Content Engineers and someone will respond to this post shortly.

Tara McCoy
Highlighted

@s_pichaipillai thank you for looking further into this and adding some useful experimental data to the discussion!  I appreciate your time and effort in looking into this for both myself and the community!

Highlighted

I'm going to guess it doesn't like the spaces in the name of your temp directory.

 

The macro I think needs to be fixed such that the command line arguments in RunCommand looks like:

 

/c echo %cd% > "%temp%__temppath.txt__"

 

(note the quotes)

@StevePasetti (I don't think I'm doing that right), that worked.  I made the change and saved a local copy of the macros (can't overwrite standard tools) and ran it.  I'll forward your answer to the CSR with whom I'm working.  Great solution!

 

The top one is the original macro, the bottom is the macro with your change:

fieldsummaryfix.PNG

Labels