Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Community v19.6

Looks aren't everything... But the latest Community refresh looks darn good!

Learn More

Fast Timeout on Connect In-DB Microsoft SQL OLE DB


I'm experiencing an almost immediate query timeout on one of my Connect In-DB queries to a Microsoft SQL server using OLE DB driver.  I have three of these objects all using the same connection.  Two of them run in a second or two just fine.  The third runs for maybe 10 seconds, then times out.  It is a large query, but the timeout on the server end is set to several hours (I can run a nearly 6 hour query in SQL Server Management Studio just fine).  Does anyone have any suggestions as to why this might be happening?  Thanks.


Hi @CharlieBeer,


I have not experienced this scenario myself, but an idea would be to run each of these 3 queries as a macro and bring back all relevant results back into your main workflow.


If there is some overlap, concurrency issues that breaks your 3rd query, provided it runs file in isolation - adopting macro approach will give you the same.





#Excuse me, do you speak Alteryx?



    Thanks for the suggestion, but I've already tried isolating each query.  The first two run perfectly fine still, but the third query times out even if completely isolated.  That is, I created a workflow with just that query and a Browse In-DB and get the same timeout in about 10 seconds still.


    Weirdly, if I run the exact same query as a normal Input Data, it takes a couple minutes, but completes just fine.  I'm trying to work In-DB as much as possible since it is quite a large query, especially when I scale up to the full target data set rather than just this (relatively) small sample.


- Charlie


Not sure if this will help, but I had the exact same issue. The cause was that I had a Data Stream Out tool with input from one of the other inDB tools, but the Data Stream Out was NOT output-connected to anything else. I deleted the errant Data Stream out tool and it resolved the immediate query timeout.