Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Announcement | We'll be doing maintenance between 9am-11am MT on Saturday, January 25th, which may impact your experience. Thanks for your patience as we work on improving the community!

Failed sending data to the peer

Alteryx Certified Partner

I use the email tool quite a lot, but recently some have been failing! This is the error message:


00:01:4.401 - Error - ToolId 91: Record#1: Failed sending data to the peer 


I set up the tool (SMTP, port, etc.) the same across all instances of the email tool, but it seems to work for some (most) but not others! Any ideas?


I run this workflow on server (the email tool can't be run from designer at my organisation).


Hi Rachel,


an option might be that you are blocked out by the mail server caused by too many (parallel) login attempts.

I had a similar problem with AWS SES, changing the port resolved it for me.


Or the easiest option, check your password again, this might also cause this error message (e.g. gmail)


Hi Rachel,


We just ran into the same issue (Failed sending data to the peer) and it turned out to be a bad email address (contained two @ signs in the address). I'm sure you've checked for that, but it was easy to miss as we thought we tested different combinations of bad emails.



Alteryx Certified Partner

Thanks @hybird21 and @DavidSta for your suggestions. I don't think it is either of those because I've manually checked the email addresses, which is just a short list of around 11 possibilities (and why would it work on some workflows and not others?) and the workflows that don't work, don't work even when I run them manually from server (so wouldn't be too many parallel requests). I don't have any password details embedded in the tool/workflow.

My next step will be to check the workflows that do work to see if I can identify any differences between those and the ones that don't.


Did you resolved this issue ?  I get the same but only when I attach a spreadsheet to send. It works fine emailing out without the attachment.

Alteryx Certified Partner

No, could not get to the bottom of this. None of my mails have attachments, other than tables (which they all have - both the ones that send and the ones that don't). I'm still looking for a solution and appreciate your suggestions.


I've resolved mine. The peer it was referring to was the smtp server. It was getting an RFC violation and the smtp was stopping it going out. Check with whoever is admin for your smtp and see if it's that server that's stopping your mails from going out. If they lift some of the restrictions for your alteryx server it may work.


Good Luck.

Alteryx Certified Partner

UPDATE: Managed to get it fixed by swapping the delimiter "," for ";" between email addresses!


Did you get that error back from your smtp admin ? or just realise that was the cause ?

Alteryx Certified Partner

It was suggested by a colleague when he saw that the unsuccessful attempts were when there were multiple recipients.