Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

General Discussions has some can't miss conversations going on right now! From conversations about automation to sharing your favorite Alteryx memes, there's something for everyone. Make it part of your community routine!

Excel Sheets Not Being Read

thegarrettp
5 - Atom

I'd built a process not using Alteryx on files delivered from an e-mail scheduled report.  I used powershell to extract the datasheet, save as a CSV and then ingest like normal.

 

When I switched to Alteryx I had the same issue here as something is off with the excel files...  From what I can finally deciper, the generated excel files are missing their <?xml declarations, which by opening in excel and re-saving it effectively fixes the formatting to be "correct" and what Alteryx expects.  I've battled trying to wire up a powershell script to automate the open and save, but I don't know that's going to be compatible on our server.

 

On a hunch, I thought about trying these files as .xls or Legacy xlsx... and so far it's worked!

  1. Use input data tool
  2. Select excel file
  3. Get the sheet selection dialog box
  4. Select "cancel" as it can't read any sheets
  5. change Input tool "File Format" to "Microsoft Excel 1997-2003 (*xls)" or "Microsoft Excel Legacy (*.xlsx)"
  6. I now get an error that I must select a data sheet
  7. Re-try selecting the "Table or Query" in the tool settings.

Initially I got a Jet driver error when trying the .xls option - following this information here https://community.alteryx.com/t5/Engine-Works-Blog/Access-Driver-Install-for-xls-File-Acess/ba-p/901... I'm able to fix it.  Now I just need it installed on our Alteryx server...

nsalva
5 - Atom

@Muizz did you find a resolution to your issue? I am also experiencing the same problem and I need help ASAP.

 

Thank you,

Ngoc

Tomasz
6 - Meteoroid

Thanks for a good advice!

 

In my case, choosing "Microsoft Excel 1997-2003 (*xls)" for my *.xlsx file solved the problem.

Labels