Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Excel Files Won't Update in Scheduler Mode - No Error Log

6 - Meteoroid

Hi! I have a flow that will run correctly if triggered manually and will save over specified excel sheets.


However, the same flow will run in Scheduler mode, say it updated the excel sheets, even update the DateTime on the file itself, but it does not actually update the records in that excel sheet or record any errors in the output. It's like it thinks everything is fine and updated correctly.


I have verified that it is running in UNC and have told it to "run as" me since the files are located on a server/shared drive.


Has anyone else experienced this? I feel like there should be some error for me to investigate 

10 - Fireball

When you uploaded your workflow in to the scheduler, did you verify that you had the Excel files unchecked as File Assets? If they are checked then the workflow will store the static files in the MongodB and use those to run when the workflow is scheduled to go. If they are unchecked, then the workflow will look at the filepath and try to pull the file in from the network location.




6 - Meteoroid

Hi Paulteryx! Thanks for replying. Can you tell me where I would find that setting? I don't recall encountering it during the setup process. The issue is specifically for writing to the output excel files after the flow has finished running. 

6 - Meteoroid

Also, I may need to further specify that we don't have Alteryx server. Just the scheduler and design tools. The server I was referencing is the shared drive where these output files live. 

10 - Fireball

It's when you schedule a job.


See below and make sure your input files are not checked.



6 - Meteoroid

I believe that's only an option if you have Alteryx sever. My only choice is to set the schedule location to "my computer." We do not have a gallery.

10 - Fireball

Ahhh that's right. In your case, make sure you click the radio button that allows you to run the workflow from a specific location; rather than the option to upload the workflow to the database. That should get you the results you're looking for. Just make sure you don't make changes to the filepath after you set up the schedule

6 - Meteoroid

Thanks! I had tried that last week (and just tried it again) but I get a "corrupted" status and it doesn't run:




6 - Meteoroid

This is resolved. Our IT made a change to the server permissions that caused this. They reverted them and now this is working. Thanks for the help!

5 - Atom

We have the same problem. Could you let me know which server permissions were updated with your company? Thanks