Inspire EMEA 2022 On-Demand is live! Watch now, and be sure to save the date for Inspire 2023 in Las Vegas next May.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.

Errors Moving Batch Macro Workflows

6 - Meteoroid

Has anyone else experienced this?  I'm running a bunch of macros in a batch and can't move the base workflow without them all erroring out.  See first the working version below:

Batch macro that works.png


Each takes in 'Name' and spits out a bunch of data.  Works great.  Now, when I tried giving this to my coworker to run, it showed an error on opening, and all of the macros showed up as question marks without macros tied to them (see below).



Error when it fails.png


Failed workflow:



All of the macros were included, he'd updated all of their file references beforehand, and everything should have been good, but it didn't even seem to know they were macros at all.


What really got me: I can open the workflow from the Dropbox folder I moved it into, and it works fine.  When I move it and all of its files back to my machine?  Error City.


Now, I can go and add in all of the macros individually, and they'll work, but I'd rather learn what's wrong here and how to either fix or avoid the situation in the future.


So far, I've been able to make this happen with workflows running one single batch macro as well, so it's not data size, as far as I can tell.  I'm also already running 10.6.


Anybody know about this?





17 - Castor
17 - Castor

@charlescolemansm On the computer that works, can you open the base workflow with a text editor (like Notepad) and find the lines like this: <EngineSettings Macro=".\Batch.yxmc" />


Post back and let me know what it reads for one of the macros that stops working.


This setting is determining where the workflow looks for the Macro.  I think there are 3 different ways to set it up:

1) relative (.\batch.yxmc)-You would need to make sure the macros are moved with the workflow and saved in the same directory.

2) Absolute (C:\Data\batch.yxmc)-You would need to make sure that they have access to the directory with all the macros.

3)Macro Directory (batch.yxmc)-You would need to make sure they either have a macro repo setup the same or just move the macros to the same directory as the workflow.


Based on the way the xml is setup, I'd be glad to try and help further.

6 - Meteoroid

Wow, good call.  


I'd had them set up in Alteryx as .\batch.yxmc, as they are in the working version.  Copied and pasted the file twice, and now it's showing ..\..\..\..\..\..\<file path on my computer>\batch.yxmc.  I went back through the broken version and replaced all of the paths with .\batch.yxmc, and everything worked again.


Any idea why it would change?


Regardless, thanks for your help!  I really appreciate it.