community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Error with Salesforce Output Tool

Highlighted
Meteoroid

When I try to use the Salesforce Output tool, I get the following error message:  “Error: Salesforce Output (3): Tool #4: Parse Error at char(0): Type mismatch in operator +. (Expression #3)“

 

A more detailed explanation is:

 

I was trying to update a contact field number field in Salesforce.

 

  1. I am doing a download using the Salesforce Input tool of two fields – id and count_of_keywords from the contact record for one contact
  2. I am then try to do a formula to set the field to 3  (I also tried 3.00 and a string)
  3. I then try to update Salesforce and I get an error message in the Salesforce Output tool line “Error: Salesforce Output (3): Tool #4: Parse Error at char(0): Type mismatch in operator +. (Expression #3)“

 

I removed the formula and I still set the error.  I tried to include all fields and I still get the error.  The record can be updated in Salesforce (passes validations, etc.)

 

What should I be doing?

 

Screen prints are supplied below.

 

Thanks for any help you can provide.

Bob

 

 

 

 

This may be the problem (I ran with the SalesforceOutput page up) – we do not use security tokens:

 

 

 

 

 

 

Moderator
Moderator

Hello @BobC 

I would recommend checking your data types that are coming into Alteryx from Salesforce, you can do this using a Select tool.

You can change the data type from here, and this may help you to achieve the correct result.


Please let me know if you have any other questions.


TrevorS

Community Moderator
Meteoroid

Thanks for the reply.  

I worked with a more experienced user and we added the select tools as you mentioned today. It still did not eliminate the issue.

I may be having trouble in authenticating or connecting (see in the doc where it is failing), but I am connecting in the GUI for the Output Tool since the drop down works, etc.  

Atom

Error: Salesforce Output (10): Tool #4: Parse Error at char(0): Type mismatch in operator +. (Expression #3)

 

Has anyone been able to solve this issue?

 

I am having the same issue, and I have attempted to change the data types on the three fields I am updating with no luck. 

 

Thanks in advance. 

 

Meteoroid

Alteryx support was able to eliminate the issue after a few webex's.  Our SF environment doesn't require a token and I believe they had to remove the token from the password for my copy of the tool.    

Labels