community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Error while using a R package

Asteroid

I tried to install an R package (dplyr) using this link (https://gallery.alteryx.com/#!app/Install-R-Packages/57bb2a58a248970b4472c2e6) in alteryx gallery. After installation when i tried to run a code that requires this package, Alteryx is throwing an error (Error: R (5): Error in library(dplyr) : there is no package called 'dplyr')

Any solutions?

ACE Emeritus
ACE Emeritus

One thing you could try is just to put install.packages("dplyr") right in your R tool... try running it.   If it runs successfully, then you can remove that line on subsequent runs.

Alteryx Certified Partner
Alteryx Certified Partner

Hi,

 

I have successfully installed and opened this package to my machine.

 

I have had these folders a while so do not know which the dplyr package is dependant on running but I have uploaded my entire library here.

 

If you download this and paste the contents into the following path "C:\Program Files\Alteryx\R-3.2.3\library" and then run your code it should open successfully.

 

Note you should replace any conflicts when pasting the contents of my library in yours. The dplyr package contains dependencies which need to be the latest versions.

Ben

Meteoroid

I copied it as you mentioned but still the same error displayed, please advice.

Meteoroid

 


@BenMoss wrote:

Hi,

 

I have successfully installed and opened this package to my machine.

 

I have had these folders a while so do not know which the dplyr package is dependant on running but I have uploaded my entire library here.

 

If you download this and paste the contents into the following path "C:\Program Files\Alteryx\R-3.2.3\library" and then run your code it should open successfully.

 

Note you should replace any conflicts when pasting the contents of my library in yours. The dplyr package contains dependencies which need to be the latest versions.

Ben


I copied it as you mentioned but still the same error displayed, please advice.

Alteryx Certified Partner
Alteryx Certified Partner
Can you confirm which version of Alteryx you are running? Ben
Meteoroid

The Version is : 10.6.8.17850

Alteryx Certified Partner
Alteryx Certified Partner

Are you in a position to share the workflow you have? 

 

If so if you could export it with dependencies that would be great (options > Export workflow).

 

Ben

Meteoroid

The problem solved when we shift the setting to be under R\R-3.3.2 this is the whole Idea.

 

I'm really frustrated from those tools like (Altryx) they do a propaganda ad (The best and easiest tool for Integration) while the case is opposite, everything is very difficult In particular with R .   I think we have to shift the setting in every workflow  related to r From (Altryx\R-3.2.3) to R\R-3.3.2 to work properly (we might also find more bugs)  , what about the environments that don't have (R) ? I can deploy this workflow because I have R environment, but when we go to the production we will face the same error problem in case if the deployment workspace without R.  As analysts in R, we spent the majority of time to fix our code and setting that loose our energy in something not related to our core in Analytics , so please altryx don't claim that you solve all business and system cases , I think we have to forget our previous experience and start from scratch to work purely with altryx.

 

Thank you and sorry for the frustration feeling 

Meteoroid

I get red of Alteryx with R, Please see the powerful and easy to use without complicated processes in (pentaho)  compared to Alteryx

 

http://www.pentaho.com/announcement/data-science-pack

 

And look how big is the steps between Alteryx and (Pentaho), no more headaches, Bay for Alteryx .

Labels