Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Error when using Excel Legacy for output

Highlighted

Hello Guys!

 

I'm using a solution in Alteryx Designer and the output is a MS Excel file with Excel (.xlsx) with Overwrite Sheet (Drop) selection.

 

I need to change it to MS Excel Legacy (.xlsx) format in order to allow the solution to use the Delete Data & Append so I can use the existing layout at the Excel file.

 

But I've encoutered several errors with the MS Access DB, the first one was referred as:

 

Error: Output Data (3): Error creating table "table_name": Microsoft Access Database Engine: Invalid precision for decimal data type.\3700 = -99878389
CREATE TABLE...

 

I've changed the data type from Fixed Decimal to Double and it didn't worked, it showed another error:

 

Error: Output Data (3): DataWrap2OleDb::SendBatch: Microsoft Access Database Engine: Operação OLE DB de várias etapas gerou erros. Verifique cada valor de status OLE DB. Nada foi executado.
Insert into `sheet_name`...

 

Note: My MS Office main language is PT-BR

 

I've reinstalled the MS Access 2010 (Version 14.0.7015.1000) 64 bits and it still didn't worked and showed up the same error.

 

Did anyone experienced the same or a similar issue? So far I didn't found a solution for it.

 

 

 

Highlighted
Alteryx
Alteryx

What's are the formats of the columns in Excel?

 

Does Alteryx correspond for each one?

Highlighted

Hi Joe,

 

The Excel types are General and the origin files information are from a SQL Server Database.

 

The types from origin are V_String, V_WString, String, Int32, DateTime and FixedDecimal (or Double), the error only appears when using the Excel Legacy.

 

 

Highlighted
Alteryx
Alteryx

Hi @Gabrielfeb 

 

Thanks for the info, could you try using all double instead of Fixed Decimal? 

 

I am wondering if the formatting differences between the two is causing the issue.

 

Failing that, would it be possible to upload your template and a data sample for me to test my side? Feel free to private message me if you don't want to share publicly.

Highlighted

Hi Joe!

 

Found a solution at the Alteryx Community, I've followed the steps as this topic

 

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Output-legacy-Excel-files/td-p/8819

 

In some files it worked fine, in others I had to change the Decimal type to Double type and worked fine.

 

Thanks for your time and assistance! 

Labels