Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Error reading the dictionary - filename may be invalid

Alteryx Partner

I am working with about 17 .sas7bdat source files. I loaded them in the canvas, created a workflow, multiple joined on a unique ID and generated tableau data extract .tde output file. I am able to successfully perform this for 16 out of 17 sas files. For one of the source sas files, when I load it in canvas I receive an error "Error reading the dictionary - filename may be invalid"


There is nothing invalid about the filename (it is in same format as rest of the files) so I am not sure why I am receiving this error. Any thoughts??


alteryx error.png

Community Content Engineer
Community Content Engineer

hi @jshah120 - what is the full file name?  Thanks.

Alteryx Partner


Community Content Engineer
Community Content Engineer

no weird characters in the [...] section?


How large are the files?  Does it open correctly in SAS?

Alteryx Partner

No, the location of the folder is same as rest of the other sas files I've used in Alteryx workflow. It's just this one file when I drag into canvas it shows this error.. other files are fine

Alteryx Partner

This file is about 850 MB. It opens correctly in SAS. The other 16 sas files range from 500 KB to 4.4 GB

Community Content Engineer
Community Content Engineer

Can you change the location of that one file, for testing purposes? 

Alteryx Partner

That worked! I moved it to Desktop and it loaded it to Alteryx, and it worked just fine. This is so weird!

I had the same error, but changing the file location didn´t work. 

Any insights as to what may be the problem?


I am also receiving this error even though I am using version 11.7.4 (upgrading was suggested on another thread). I have also tried this solution (reading from desktop) to no avail. Any further ideas on this one?