Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Register for the upcoming Live Community Q&A Session - and don't forget to submit your questions for @DeanS regarding the future role of analytics here.

Error in linear regression: The field Fit_Stats is not contained in the record

6 - Meteoroid

Well I ruled out McAfee because I literally bought Bitdefender in case it was McAfee causing the problem. But after Alteryx reinstall, I've got the same error.
However, I have active at all times CCleaner, Malwarebytes and Cybereason Ransomfree (yeah, I'm freaked out about security haha). Tried disabling all of them and same error. I'll try to whitelist Alteryx the s**** out of every whitelist I can find in my computer and softwares and see if it's any firewall or something. I'll let you know, thanks for laying it out.

6 - Meteoroid

Yupp, DavidxL was right. Although I couldn't run Alteryx in my environment, since I didn't want to unninstall my antivirus and other programs, so I Installed VirtualBox, installed windows 8.1 in a virtual machine and installed Alteryx in it.

It finally worked!

If anyone wants to try this workaround, I can provide tutorial links.



5 - Atom

I met the same question like you, would you like to share the solution for me?

Thank you!

5 - Atom

屏幕快照 2019-08-14 23.16.14.png

6 - Meteoroid
Bro, my issue was (90% sure) probably related with antivirus. I had McAfee
and malwarebytes premium running at the same time. Although I deactivated
them, whitelisted almost all Alteryx files, and did not want to unninstall
any of those programs, it still didn't work for me.

What I did was download VirtualBox free, install a downloaded version of
windows 7 and there I installed Alteryx. Everything worked fine there.

So you can either test unninstalling software that have admin rights to
your files, reformatting your pc or if you don't want any of that and if
you only occasionally use Alteryx, then use a virtual machine.

8 - Asteroid

I am doing the predictive analysis course also on udacity and im seeing the same problem, i know i refreshed my install no longer than a week ago.  with predictive added a few days ago.


Anyway, i do have mcaffee, but this is a work computer and i cant change much around uninstalling anti virus.


I dont think i can go an make a virtual box as a solution, maybe predictive just wont work for me.  I hear in about a years time we might get windows 10, if not i may have to try running this from my home computer when i eventually get it back from HP.


i have raised a ticket with helpdesk, so hopefully i will get a response before the end of the year.  Its a shame as i really wanted to get this working.


so this gets better, having called someone in my cardiff office they are able to run the predictive model and i cannot.  Maybe i need to think about getting this laptop re-imaged or replaced.

6 - Meteoroid
I'm so sorry to hear that. Virtual box was my "urgent" solution, since in
the forums and udacity's ticket werent being so successful in discovering
the probable cause.

Maybe with some advanced help you can track exactly which file(s) does
McAfee block, right after installing or right before running the program.

I wish you luck.

8 - Asteroid

So I have good news!  IT were in touch on Monday and said "why do you think this is mcaffee"   Then they disabled as new module which was live on my machine as I was a early adopter on the laptop I have,  as soon as that was done I as then able to run the report out with no errors!


Absolutely nuts!  Maybe IT were interested due to the topic, but they fixed this for me really quickly.


I will have to complete the other trainings which follow on from the predictive on udacity now.


Thanks to the forum, as without that I wouldn't have had a fix to the problem.

8 - Asteroid

A further update to this, which i believe should have eradicated this bug for ALTERYX.  i have had a risk rating assigned to the mcafee engine and not just for my machine, or just my company.  This is rolled out to the whole world!  its listed and safe to use the predictive R modules!  ATP  which is the real time scanning has now been fixed to accept alteryx with the DLLS which are running.


I hope that this will mean people wont have to suffer the problems when trying to complete the predictive learning modules!


hope you can all benefit from this win.   (crazy dance time)




6 - Meteoroid

I just finished predictive model training and have been playing with my own data set. 


My first attempt at running linear regression worked great. But then I added a second model to the mix and neither worked. Now, linear won't work either.


I "paused" my Windows Defender based on this thread and I still cannot get the linear regression to successfully complete. Am I correct in assuming that I'm on the right path -- or should I be doing something else to fix this?