Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

General Discussions has some can't miss conversations going on right now! From conversations about automation to sharing your favorite Alteryx memes, there's something for everyone. Make it part of your community routine!

Error While Executing a select query in Amazon Redshift

7 - Meteor



In Alteryx Designer 2018.3 , While Executing select * from Table " or any type of query via input tool to Amazon Redshift database am getting the following error "

Error: Input Data (1): Error SQLPrepare: [Amazon][Amazon Redshift] (20) Error occurred while trying to prepare a query: [SQLState XX000] ERROR: plan should not reference subplan's variable

". Could you please share your valuable thoughts ? 


Kindly Note : 


  • Same query is executing perfectly in SQL Workbench 
  • Database Connection within Alteryx Designer & ODBC is also sucessful.
  • Same Query Was executing properly couple of months back in the same workflow.
  • I tried to check the same error in google and also in other community but no luck.
7 - Meteor



Could some one share your valuable Suggestions.