community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More
We will be upgrading the Gallery to our 2019.4 release this Saturday, December 7th beginning at 9:00am MT. We expect the outage to take last approx. 2.5 hours.
SOLVED

Error: Publish to Tableau Server (2): TableauServer.Login: Tool #4: Tableau Server API

Hi guys,

 

I am getting the following error,

 

Error: Publish to Tableau Server (2): TableauServer.Login: Tool #4: Tableau Server API Request (Sign-in) Error Code 404001: Resource Not Found -- Version '2.2' is not a valid version of the API.

 

Here's what I have:

0. Alteryx version is 11.0.6.28907 x64
1. Tableau version is 9.0.8 (9000.15.1104.1800)

2. Tableau site role is Publisher

3. I am using Connect with server and site

   i. Server URL: https://analytics.corp.MYCOMPANY.com/

   ii. Enter Site name: MYCOMPANY

4. Login credentials I use are the same ones I use to login via web browser.

5. I selected Publish data source

   i. Enter data source name: EA_Test

   ii. Select project name: None

   iii. I checked Refresh project name list

 

 

Any help would be much appreciated! Thank you!

Bump

Bolide

Does it work when you run it manually from your desktop build?

Alteryx Partner

From Tableau online help I can see that Tableau Server 9.0 use an API version 2.0.1.

 

http://onlinehelp.tableau.com/v9.0/api/rest_api/en-us/help.htm#REST/rest_api_ref.htm

 

I assume that that Macro you are using use an API version 2.2.

 

So it would work just with version of Tableau Server 9.3+

 

I have checked on the Alteryx Gallery and I unfortunately I have found a "Publish to Tableau Server" Macro that works just with Tableau Server 10.0+.

publish to tableau server.JPGhttps://gallery.alteryx.com/#!app/Publish-to-Tableau-Server--Installer-/5926021ceffc2a0b7cc2bc44

 

 

 

 

I have exactly the same problem but have Tableau server 10.2.3  and Alteryx V11 I downloaded v1.08.1 of the tool the error message I get is 

Error: Publish to Tableau Server (18): TableauServer.Login: Tool #4: Tableau Server API Request (Sign-in) Error Code 401001: Signin Error -- Error signing in to Tableau Server

Alteryx Partner

Hi, I also have the same problem.

 

But i have installed the latest version of Publish to tableau. Now i am not able to install the previous version .

 

Can You please help.

Asteroid

@iankruger

 

Hi,

 

Did you ever get this fixed?  I'm getting the same error message.  Initially, I was getting it with Alteryx 11.5 and Tableau 10.3.  And now I have Alteryx 2018.2 and Tableau 10.3 (we will be upgrading to Tableau 2018.2 within the next week), and I'm still getting the same error.

 

Were you able to fix?  If so, how?

 

Thank you so much,

 

Asteroid

@iankruger

 

I'm still using the previous version of  the "Publish to Tableau Server" tool.

 

After we upgrade to Tableau 2018.2, I will update the "PtTS" tool.

 

Thanks again,

 

No we did not get this fixed, but I think we identified that it has to do with the perculiarites of our AD accounts where Tableau Server is expecting a different  security token from the one we normally login on through our Single Sign on (SSO), MInd you we never did investigate further if this was indeed the case. We just published to a table space that had a link to Tableau Server instead

Asteroid

@iankruger

 

Thanks...

 

I'll let you know what happens from our side...

 

Thanks again,

Labels