Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here

Error Message DataWrap2ODBC The SLOB Parcel is incorrect

Highlighted
7 - Meteor

Hi,

 

I am exporting my Workflow results into an ad hoc table and I get the error message 

 

Start: Designer x64: Started running Wflo.yxmd at 09/06/2019 07:41:55
Error: Output Data (16): DataWrap2ODBC::SendBatch: [Teradata][ODBC Teradata Driver][Teradata Database] The SLOB parcel is incorrect. Insert into "database name"."tablename"("C1","C2","C3","C4","C5","C6","C7","C8","C9","C10") Values (?,?,?,?,?,?,?,?,?,?)

 

I have changed the table name, column names and database name.

 

Here is what I have done.

 

I am caching my inputs - i tried by not doing that but same error message. 

 

sometimes it gives me error 

 

Error: Designer x64: The Designer x64 reported: InboundNamedPipe::ReadFile: Not enough bytes read. The pipe has been ended.

 

Highlighted
11 - Bolide
11 - Bolide

Hi @maniruddha,

 

Having some experience withing with Alteryx + Teradata myself, i know that similar errors could be caused by data records not aligned with table schema definition/field types and/or names.

 

In the past i run out of INT range and also STRING length with new data - extending these helped in both occasions.

 

What do you mean by ad-hoc table, is this a truly temp table - created on the fly and destroyed with a post-SQL or do you have a pre-created table that you recycle every time?

 

If former - this theoretically should work, however i know that the types that Alteryx suggests are not always 100% optimal, if latter - this can easily be the case that your new data is not aligned with table definition (field names, types etc.).

 

In the past, when i came across similar problem, i tried to isolate it to a problem record/range of records running in batches or one by one (you can use Select Records tool here) - i know this is not ideal, but the problem becomes apparent when you compare the specific record causing troubles and even specific field value with the schema of the destination table.  

 

Hope this helps, let me know how you get on!? 🙂

 

Thanks,

Rafal

 

#Excuse me, do you speak Alteryx?

Highlighted
7 - Meteor

Thank you for the conversation.  Still couldn't figure out

Labels