community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

Error: Designer x64: The Designer x64 reported: AlteryxProcessManager::Start: ConnectNamed

Meteoroid

Hello,

 

I am getting below error while trying to run the work flow. The work flow ran fine till yesterday. NO changes made to my PC.

 

Error: Designer x64: The Designer x64 reported: AlteryxProcessManager::Start: ConnectNamedPipe: Error in ConnectNamedPipe The pipe is being closed.

 

I saw other post which talks about this error, and solution was to white-list Alteryx, i tried doing this but on my PC, but i don't have any policy which restricts specific programs to run, so everything should run as expected.

 

The other issue i see here is even when creating new WF, i am not able map fields from file input to next activity, this is at design time.

 

Any idea how to overcome this issue?

 

 

That error could also be due to:

A corrupted source file.

Inadequate memory on the machine.

Inadequate disk space on the machine.

If it's using any of the packaged data (like CASS or Experian); reinstall those.

Meteor

Same here.  The upgrade to 2018.1 has been disastrous.  Hopefully downgrading with solve the issues.  My computer has plenty of disk space.  Plenty of RAM.  And the XML files are not corrupt.

@patrick_mcauliffe has nailed some of the most common reasons for this error.  If the file it is attempting to load is a .yxdb, try loading it in a separate workflow with just a browse node.  If it still generates the same error then my best guess would be file corruption.  We've only had this happen once, when we migrated a file from one server to another, but after the move the .yxdb always generated this error.  No clue how corruption happened (the move had checksums verified) but we just recopied it from its location and it was fine.

 

We've also had this error occur during momentary lapses in our connection to our file server during the middle of a workflow.

 

Can you give us more information about the workflow you are running and what the data sources are?

Meteor

Pulling data from Oracle. A few tables and a date range with a few other constraints. Nothing major. Worked fine in 7.xxx.

Pulling the .yxmc/.yxmd off a local hard disk.



Mark Cimini
Senior Principal Systems Engineer

I don't work with Oracle so I'm not able to help you troubleshoot entirely, but can you try using a different driver when connecting to the database?  It may be an issue with the newest drivers and so using an older one might still give you the results.  This error is fundamentally telling you that the data it is receiving through a connection is not formatted consistently with what it expects.  That can occur because of a problem with the data itself, or because the connection drops midstream and fails to recover (leaving you with a row that is not properly formatted).

Meteor

I'm having this error as well.  Can't even use the input tool and a browse tool.  the input is an alteryx yxdb.  I am able to read the file on my laptop.  Only getting the error on my desktop.  I have not seen a solution to this.  I just emailed support.

Bolide

“Start: ConnectNamedPipe” Errors that occur when attempting to run the flow...at very beginning are in my experience due to security software like McAfee ATP (active threat protection).  Bear in mind Alteryx is a "Load & Go" type of high level programming language that when you press "play" it runs a series of programs and snippets to transform your GUI workflow into a machine language executable form.  These newer types of protection software, even when in "Observe" mode, will intercept and analyze all that activity to score it as a risk or not.  This can at times cause delays in the interconnected events, thus ConnectNamedPipe error, basically a thread between 2 or more activities time out.

 

Another error we saw frequently before sorting this out is "Root Element Missing".  this usually occurs when you open a flow and click on an input or dynamic input that has SQL.  The issue here is the delay we are experiencing cause the initial DB query to get Table info failed, probably for timeout, and so you get a Root Element Missing error.

 

Be aware that errors “DataWrap2_ConnectNamedPipe after 11000 milliseconds” are a different issue, this seems to be a connectivity timeout, to NAS storage or some other data appliance.

 

The idea of a white list is to identify programs, files and or folders to exclude from the security program's process.  

 

The attached pics are what we implemented with success for both Admin and non-Admin installs

 

 
Meteor

I was able to solve this problem by going into McAfee Security Center, Real-Time Scanning, and whitelisting all Alteryx*.exe files in /Program Files/Alteryx and all *.DLL files in the CASS data files.  I was not using other data services beyond CASS, but I imagine I would need to whitelist the DLLs for the other services if I was using them.

Meteor

I have found that this wasn't a security/white list issue for me.  I just need to select the tool and hit F5 a few times, sometimes trying a few of the tools.  Seems the workflow needs to re-read in some of the files or something.  I have gotten this issue sporadically and F5 has been working.  Try the tools and the connections.

Labels