Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More

Error-DataWrapOCI: Unable to Prepare the Query

I'm having an issue streaming data out with in-DB tool.  I'm getting the error "DataWrapOCI: Unable to prepare the query: "With Tool1_Oaaf" AS query...."




Can anyone tell me what this error actually means?  The query works if I run it in TOAD or SQL developer.  


Hi @JordanHowell,


Would you be able to provide the full error message? With these types of error messages the important bit it usually at the end. You can copy and paste the error message from your results window.




I woudl love to however, the error message was not saved.  My apologies.  What I do is within the SQL query filter, I changed a dynamic date field that went off a system date and replaced with a hard date field.  At that point, it worked fine. 


I've got a similar Error Message when using Formula In-DB. 


In my case I had a workflow built with non-In-DB tools and I'm trying to rebuild it with In-DB. On the Formula In-DB I'm just trying yo create some variables that are the result of subtracting 2 existing variables and the error I get is the following :


Error: Formula In-DB (314): DataWrapOCI: Unable to prepare the query: "WITH "Tool312_d163" AS (SELECT * FROM "AYX170209c38e62e18b504240c2cc5") SELECT "Name", "Year", "A", "B",  ("A"-"B") AS "C" FROM "Tool312_d163"" Error: ORA-03001: unimplemented feature


But I don't know what it refers to. Any help?


Many thanks,




I was getting the same error when trying to specify a date in a query to Oracle with the Input Data tool.  Originally, I had this clause: when cm.MEMO_DATE>='20171001'.  This worked in Oracle SQL Developer but not Alteryx.  I found that changing the right hand side to To_Date('20171001', 'yyyymmdd') did the trick.  It seems that may be a date formatting issue when sending hardcoded dates and using the Oracle To_Date function appears to ensure that it was cast as a date.


I have encountered the same error. As my queries were running fine in SQL developer.

The issue with my query was a very simple one. It was ending with  a semi colon(;). As SQL developer supports semi colon at the end of the query so there was no issues in executing it.

However copying the same query in Alteryx and removing Semi colon from the end of the query resolved the issue.


Nice Job! Unfortunately, I did not see this after spent 2 hours rewriting my query that worked perfectly fine in Toad. 2 hours for a ; thumbs up!


Nice Job! Unfortunately, I did not see this after spent 2 hours rewriting my query that worked perfectly fine in Toad. 2 hours for a ; thumbs up!


One semi generic solution (Oracle) is to set NLS_DATE format or to use the pre-SQL like this:


alter session set nls_date_format='yyyy-mm-dd hh24:mi:ss'


Worked for me. This problem occured when i upgarded to version 11.8.4  (worked in 11.4 )


I had this error when I was trying to connect to the wrong DB.


Check that too.