Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Empty string cells in Excel file processed by Alteryx and loaded to Oracle


We need to load Excel files that we produced using our Alteryx workflow into our Oracle based solution. Unfortunately, after we load the Excel file processed by Alteryx, the fields which type is String are empty. Cells are being loaded, we can see the cells, we can see that cell data types are strings, it's just the values are not accessible for some reason, the software shows them as empty values. The values for fields of the other types i.e.  Int32, are accessible.


What is important is that when we open the file produced by Alteryx in Excel and save it, all the values are accessible when we load this to Oracle.


On Alteryx side, we have tested various String types, each time getting the same results. I have attached the sample workflow and the sample Excel test file.


This is the file processed by Alteryx:

TEST CLIENT1122334IT0123456789111/222/333Italy2018_JUL01_JUL31186040


This is what we see in our Oracle solution:

 1122334    186040


I am also attaching some feedback from our Oracle developer which is still investigating the issue on his side:


“… The file is being read into a BLOB. Then I tried 2 different Oracle-based developments to process it. The first is a freeware called AS_READ_XLSX. It's a very basic thing which gives you access to all the cells in an XLSX document using Dbms_Xslprocessor and Dbms_Xmldom.

The second is called PLPDF and we bought a license for it. It's also an Oracle based development to work with excel,  PDF and XML documents. This is more sophisticated then the freeware, but also basically gives you access to all the cells.

The results were the same for both tools: in the tab DeclarationInfo both can only see values for client code and job number, the rest of the cells have empty values  according to both tools…”


Hi @Wojtek


Since no-one's replied, I'll take a stab at it.  


Are you sure that your is being written in the format you think it is?  Have you dumped to an xml file to validate?  Once the data is in Oracle, have you tried to retrieve it using SQL Plus? 


Edit: i just ran your workflow.  The output is xlsx is correct.  Is the problem occurring outside of alteryx?  How is the file loaded into oracle? Is it through the 3rd party tools, you mentioned?




Hi Dan,


I did not try to dump it to xml., however the test workflow I attached is very basic and the fields are clearly Strings.

Yes, the problem occurs outside Alteryx. See the bottom of my original post - I included there information from our Oracle developers which describes, how the file is loaded into Oracle.




Hi @Wojtek


Since your workflow works as expected and the problem occurs outside of Alteryx, you'll probably have greater success searching for information about the upload tools in the web in general.