Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Don't forget to submit your entry for the Excellence Awards by October 30! | Need more information about the program? Check out the blog here
SOLVED

Email Tool Not Sending to emails in "TO" field

Highlighted
6 - Meteoroid

Hello Community! 

 

As of this morning, a workflow that has been working perfectly is no longer sending emails to a list of email addresses that I have in the "TO" Field yet it is not saying that it failed. I am at a loss for what could be happening as nothing has changed system wise at our organization.

 

Additionally, the body of the text is all code:

 

Here is a snapshot of the email:

zrotuno_0-1594913592436.png

 

Basically the workflow is pulling in all the email addresses from an excel file that is then matched up to each DC location and I am using a multi row formula to pull them all together and then using this field as my "TO" field in the email tool:

 

zrotuno_1-1594913766923.png

Metadata:

 

zrotuno_2-1594913809745.png

 

Email:

zrotuno_3-1594913876285.png

 

I did a test to just filter on 1 DC location and the email sent perfectly but when I have several email addresses the email does not send. Any help would be greatly appreciated! 

 

EDIT: Correction, the emails in the "TO" field are receiving the emails but they are not showing in the "TO" field when I view the email in Outlook.

Highlighted
10 - Fireball

It's difficult hidden rule that everyone in the TO: Field must be a valid email address inside your company, so I would take all the email address from you your spreadsheet of all of them, and paste them in what ever Email Application you use an find a "Check Names" like function to verify all the email address.  As the invalid email address could be anyone in the list, not necessary the first email address, it could be any one of them. 

Highlighted
6 - Meteoroid

Thanks! I did that but I will check again.


Why would that make the body of the email turn to all text and code?

Highlighted
10 - Fireball

Then changing the email to text is because of bug in the version of Alteryx Designer your using.  Let me figure out the version with that problem,

 

Highlighted
10 - Fireball

Problem in version 2019.4.6.21113
Fixed in version 2019.43.22007

Highlighted
6 - Meteoroid

Thanks for all your help and quick responses. I figured out the issue:

 

The emails that I am using are essentially distribution lists with several individual emails. Once of the emails groups that I was sending to had an individual email who's inbox is full. Once I removed that list, the problem was solved. Thanks again! 

Labels