Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Email Tool Broken on 2020.3 upgrade

jallen201
6 - Meteoroid

I recently upgraded to 2020.3 and had to roll back to 2020.2 because the email tool was unable to connect to Office 365 using SSL authentication. SMTP with SSL authentication defaults to port 465, but Office 365 uses port 587. None of my Office 365 SSL authenticated emails were able to send/authenticate after upgrading. I rolled back to 2020.2 and my email tool started functioning again with no further changes to the configuration. All were also working prior to the upgrade.

 

Is this a bug in 2020.3?

 

To complicate matters upon rollback, I am unable to install and import my Python packages that were working prior to and after the upgrade (pysftp) and get the following errors

 

Start: Designer x64: Started running C:\Users\jallen\Documents\Alteryx Workflows\python package installer (run as admin)a.yxmd at 09/04/2020 13:59:46
Info: Python (1): Processing c:\users\jallen\appdata\local\pip\cache\wheels\d4\53\02\181ea4f6c795b40c4f1d2022ba2ed15cf811d22975eb2e5968\pysftp-0.2.9-cp36-none-any.whl

Info: Python (1): Collecting paramiko>=1.17

Info: Python (1): Using cached https://files.pythonhosted.org/packages/95/19/124e9287b43e6ff3ebb9cdea3e5e8e88475a873c05ccdf8b7e20d2...

Info: Python (1): Collecting pynacl>=1.0.1

Info: Python (1): Using cached https://files.pythonhosted.org/packages/72/0a/c489e5fd7ed00993f0d7e96faa1b1ecbec6cb64e6fdeba1f200d3f...

Info: Python (1): Collecting cryptography>=2.5

Info: Python (1): Using cached https://files.pythonhosted.org/packages/a9/76/0298f6acb4ac5a193c4b7c25da04a397da1dc1b5bf236c7e43ba07...

Info: Python (1): Collecting bcrypt>=3.1.3

Info: Python (1): Using cached https://files.pythonhosted.org/packages/d8/ba/21c475ead997ee21502d30f76fd93ad8d5858d19a3fad7cd153de6...

Info: Python (1): Installing build dependencies: started

Info: Python (1): Installing build dependencies: finished with status 'done'

Info: Python (1): Getting requirements to build wheel: started

Info: Python (1): Getting requirements to build wheel: finished with status 'done'

Info: Python (1): Preparing wheel metadata: started

Info: Python (1): Preparing wheel metadata: finished with status 'done'

Info: Python (1): Collecting cffi>=1.4.1

Info: Python (1): Using cached https://files.pythonhosted.org/packages/c0/8f/de60e57567ed4f161c3590df39d8ce61b2d800551ac0269b01f6cc...

Info: Python (1): Requirement already satisfied: six in c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\lib\site-packages (from pynacl>=1.0.1->paramiko>=1.17->pysftp) (1.12.0)

Info: Python (1): Collecting pycparser

Info: Python (1): Using cached https://files.pythonhosted.org/packages/ae/e7/d9c3a176ca4b02024debf82342dab36efadfc5776f9c8db077e8f6...

Info: Python (1): Building wheels for collected packages: bcrypt

Info: Python (1): Building wheel for bcrypt (PEP 517): started

Info: Python (1): Building wheel for bcrypt (PEP 517): finished with status 'error'

Info: Python (1): ERROR: Command errored out with exit status 1:

Info: Python (1): command: 'c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\python.exe' 'c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\lib\site-packages\pip\_vendor\pep517\_in_process.py' build_wheel 'C:\Users\jallen\AppData\Local\Temp\tmpzhc_sau6'

Info: Python (1): cwd: C:\Users\jallen\AppData\Local\Temp\pip-install-c7327jwj\bcrypt

Info: Python (1): Complete output (15 lines):

Info: Python (1): running bdist_wheel

Info: Python (1): running build

Info: Python (1): running build_py

Info: Python (1): creating build

Info: Python (1): creating build\lib.win-amd64-3.6

Info: Python (1): creating build\lib.win-amd64-3.6\bcrypt

Info: Python (1): copying src\bcrypt\__about__.py -> build\lib.win-amd64-3.6\bcrypt

Info: Python (1): copying src\bcrypt\__init__.py -> build\lib.win-amd64-3.6\bcrypt

Info: Python (1): copying src\bcrypt\py.typed -> build\lib.win-amd64-3.6\bcrypt

Info: Python (1): running build_ext

Info: Python (1): generating cffi module 'build\\temp.win-amd64-3.6\\Release\\_bcrypt.c'

Info: Python (1): creating build\temp.win-amd64-3.6

Info: Python (1): creating build\temp.win-amd64-3.6\Release

Info: Python (1): building '_bcrypt' extension

Info: Python (1): error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/

Info: Python (1): ----------------------------------------

Info: Python (1): ERROR: Failed building wheel for bcrypt

Info: Python (1): Running setup.py clean for bcrypt

Info: Python (1): Failed to build bcrypt

Info: Python (1): ERROR: Could not build wheels for bcrypt which use PEP 517 and cannot be installed directly
Error: Python (1): ---------------------------------------------------------------------------
CalledProcessError Traceback (most recent call last)
<ipython-input-4-c17ac46974e3> in <module>
----> 1 Alteryx.installPackage(package="pysftp")
c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\lib\site-packages\ayx\export.py in installPackage(package, install_type, debug, **kwargs)
131 This function will install a package or list of packages into the virtual environment used by the Python tool. If using an admin installation of Alteryx, you must run Alteryx as administrator in order to use this function and install packages.
132 """
--> 133 __installPackages__(package, install_type=install_type, debug=debug, **kwargs)
134
135
c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\lib\site-packages\ayx\Package.py in installPackages(package, install_type, debug)
200 print(pip_install_result["msg"])
201 if not pip_install_result["success"]:
--> 202 raise pip_install_result["err"]
c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\lib\site-packages\ayx\Utils.py in runSubprocess(args_list, debug)
118
119 try:
--> 120 result = subprocess.check_output(args_list, stderr=subprocess.STDOUT)
121 if debug:
122 print("[Subprocess success!]")
c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\lib\subprocess.py in check_output(timeout, *popenargs, **kwargs)
354
355 return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
--> 356 **kwargs).stdout
357
358
c:\program files\alteryx\bin\miniconda3\envs\jupytertool_venv\lib\subprocess.py in run(input, timeout, check, *popenargs, **kwargs)
436 if check and retcode:
437 raise CalledProcessError(retcode, process.args,
--> 438 output=stdout, stderr=stderr)
439 return CompletedProcess(process.args, retcode, stdout, stderr)
440
CalledProcessError: Command '['c:\\program files\\alteryx\\bin\\miniconda3\\envs\\jupytertool_venv\\python.exe', '-m', 'pip', 'install', 'pysftp']' returned non-zero exit status 1.

End: Designer x64: Finished running python package installer (run as admin)a.yxmd in 16.0 seconds with 1 error

 

and upon rollback my crew macros for list runner broke giving the following error

 

Error: List Runner (4): Tool #3: Iteration #1: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741515
Error: List Runner (4): Tool #3: The output connection "Logs" was not valid
End: Designer x64: Finished running FirstShowtimeRunner.yxmd in 0.3 seconds with 2 errors

This too was working before and after the upgrade but broke upon rollback.

 

I deemed functioning email to be more mission critical so I stuck with the rollback. I was able to find manual workarounds for the problems that arose upon rollback

 

Any help would be appreciated.

 

Thank You,

James Allen

7 REPLIES 7
BrandonB
Alteryx
Alteryx

@jallen201 if you haven't already, can you please send an email to support@alteryx.com?

jallen201
6 - Meteoroid

Thanks. I just submitted to support.

jallen201
6 - Meteoroid

After submitting this to support, it was determined that I needed to adjust the authentication type from SSL/TLS to STARTTLS to function on port 587 with Office 365.

 

I have re-upgraded back to 2020.3 and confirmed it is working with the setting change.

 

I was also able to install my python packages after the re-upgrade and workflows using them are functioning as expected.

 

Seems that the only thing not functioning now is the list runner crew macro.

Anton_Stepanov
5 - Atom

Good day! 

 

I am facing the same error when installing Power BI Output Tool v2.1.3 in Alteryx Designer 2020.3 x64. Could you please help? 

I submitted a case to the support. The case number is 00405514.

 

Regards,

 

Anton 

KevinHarrison
8 - Asteroid

I just had this issue with my BigQuery tools. This is what support told me to do and it fixed it for me. Maybe worth a shot but I would talk to support to make sure it is the same thing. 

 

1. Download the yxi file from the gallery.
2. Rename the extension from .YXI to .ZIP
3. Extract the zip file
4. Locate requirements.txt file within Input/Output Tool folders.
5. Open and edit requirments.txt file to add cryptography==2.9.2 as the last line for both Input and Output folders.
6. Save/update file.
7. Rename the extension from .ZIP to .YXI
8. Run the installer

davidogundipe
8 - Asteroid

Thanks, this worked for me although I only had one requirements.txt file and it wasn't in the input/outputs folder!

cjones514
5 - Atom

Worked for me - Thanks!! 

Labels