Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Email SMTP Quick Question

ghmorrell
7 - Meteor

Just upgraded to 2018.3 and realized that there is no longer the auto detect SMTP option on the email tool.

 

Am i right in assuming that if the auto detect has worked before that I will be able to still use it and its a matter of finding the correct smtp settings.

 

I have found the correct server but keep getting the below error. Is this just the port being blocked or is there something obvious that i am missing. wanted to sense check.

 

Tried the "Most common" port numbers but all came to the same error

 

 Email (1) Record#1: Unable to create a socket after looping through all network addresses for {Servername:portNumber}
 

 

9 REPLIES 9
DavidP
16 - Nebula
16 - Nebula

I had the same problem when I upgraded to 2018.3, but found that all my previously created workflows with email functionality still worked. I had to put in the SMTP server settings once in a new workflow and after that it remembered it again.  I only had to enter the SMTP server url - no ports and it worked.

ghmorrell
7 - Meteor

I have found that it still works if you dont touch it but now i am having to make changes to the current processes.

 

I tried just the server name but still no luck. Getting the same error message.

DanM
Alteryx Community Team
Alteryx Community Team

@ghmorrell,

 

As you found out, if you don't touch the connection from already created workflow they will work. If you have to make changes, you will need manually add your SMTP server information.

 

https://help.alteryx.com/2018.3/Email.htm

 

Thanks

DanM

Spower
6 - Meteoroid

Hello!

I have not touched any of my previous connections however, none of my email tools work since I upgraded to 2018.3. I have tried manually entering in the SMTP several times with several different variations following the instructions in the provided link but keep getting errors. One error saying the "port number is not valid", I have used the default port (25), 587, 465 and 993, and another error saying "must issue STARTTLS command first".

 

I did not have an issue with this flow prior with the auto-detect feature.

 

Any help is much appreciated!

 

Thanks!

drahn
7 - Meteor

I have the same issue. It wasn't resolved with 2018.4. Alteryx support has basically told me it's on the list, but no ETA for a fix. 

 

My internal IT is trying to figure out a workaround but so far no success. 

 

Great that all of my prior workflows still send ok, but starting to really cause some issues that I can't create new emailed workflows.

Spower
6 - Meteoroid

Hi @drahn,

 

Depending which email server you use to send emails, I found a workaround using the "Invisio Macro pack: a Gmail integration". 


You can download here:
https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Gmail-Macro-send-emails-through-Altery...


Hopefully Alteryx can resolve this issue shortly or just bring back SMTP auto-detection!

 

Hope this helps!

RXP-YoannLeny
5 - Atom

Hi,

Had the same problem and was impossible to make it work.Nevertheless I found a workaround that works for me:

I need to copy my entire workflow and to paste it in a new workflow creation. Then I recreate the Event which send an email and it's working.

Once I make it working, if I need to change the content like the destination, I need to create a new event and delete the old one.

Also I was using an email address in "To:" that was not working. I finally use a noreply@.... and it's working. Just be sure the email address you use can send email.

 

Cheers

 

Ian_Lafford
5 - Atom

I've had the same problem, and no combination of server and port settings seems to fix it. As described by others elsewhere in this thread, I have ended up re-using old workflows and replacing everything but the email tool. But that's hardly an ideal solution.

 

Alteryx, is there no way to reinstate auto-detect?

gkakarlapudi
Alteryx
Alteryx

Hey everyone,

 

For those of you following this thread, as of the 2019.3 version of Alteryx Designer we have authentication functionality within the Email Tool. Users can now enter their credentials (username & password), select an encryption method, and connect to the appropriate port number.

 

If you are interested in connecting to a Gmail or other email service that was not previously supported by Alteryx Designer, please refer to the following knowledge base article to learn more on how to do so.

https://community.alteryx.com/t5/Alteryx-Designer-Knowledge-Base/How-To-Send-Emails-Through-Gmail-Us...

Labels