Inspire EMEA 2022 On-Demand is live! Watch now, and be sure to save the date for Inspire 2023 in Las Vegas next May.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.
SOLVED

Dynamic input not respecting data sort

SeanAdams
17 - Castor
17 - Castor

Hey all,

 

We have a data set that's used to drive a dynamic input (process upstream figures out ranges of primary keys, and then sends them downstream to the dynamic input).   However - no matter how I sort this data before it hits the dynamic input, the dynamic input is still processing these rows out of sequence.

 

We've done this sort in many ways to stress test this - regular sort component; pushed it out to SQL using inDB and then brought it back sorted;  sorted by different fields and then re-sorted;  used unique components; block until done etc, but this doesn't change this behaviour.   If I stop the process, I can see that the data set is correctly sorted going into the dynamic input, but the results coming up (in the results window) show that they are being processed out of order.

 

Is this a deliberate, designed behaviour, and if so - does anyone know a way to disable this?   If this is a defect or potential defect, happy to see if we can replicate this on a smaller scale and strip out sensitive bits.

 

Cheers

Sean

4 REPLIES 4
Ned
Alteryx Alumni (Retired)

The dynamic input tool removes duplicates in order to not run the same query multiple times.  In order to do that, it sorts on the field that you are modifying your query with.  So yes, it is by design.

Inactive User
Not applicable

You can build your own tool (batch macro) - create an input tool and have a control parameter going to it which would be your input file coming from a directory or list of DB tables. That should keep the sort order then instead of having the native-Alteryx tool overwriting your sort.

SeanAdams
17 - Castor
17 - Castor

Thank you @Ned and @Inactive User for your responses and insight.

 

Is there any XML flag that we can use to disable this duplicate check?    Reason being that we have 2 cases where this out-of-order processing is causing us trouble.

 

- Gap filler: checking for gaps between the source and target version of a table (copied from a legacy data-store to a new one) by primary key range.    Want to copy the biggest missing ranges first, so we sort this list by range size, but the dynamic input tool is resorting by primary key ID instead

- Daily ETL job:   Copy from one data store to another daily.    If it breaks half-way, we need to know that we have not introduced gaps because the dynamic input tool resorted in a different order than the data is natively stored by ascending key.

 

If this cannot be switched off in XML, I'll do the workaround suggested by @Inactive User and also post an Idea on this.

 

thank you again

Sean

 

Ned
Alteryx Alumni (Retired)

The batch macro is the way to go.  That gives you much more control of how things run.  I'm not sure the DynamicInput tool would exist if it hadn't pre-dated batch macros by a bunch of versions.

Labels