cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Dynamic feature toggle

SOLVED
Highlighted
Atom

I'd like to dynamically toggle features in the user interface of my Analytic App. The idea is to let a user supply data (columns) for a set of features but the data might not be compatible with each feature. There will be a minimal analysis that will be run every time, but the user would be able to supply additional data to enable more features. These extra features will mostly be macro's.

 

Scenario 1: user submits the minimal required data, turns 0 extra features on. Gets a minimal report.

Scenario 2: user submits a lot of data (many extra columns) and toggles a feature, a sub-menu item expands with a drop down of headers. Here the user selects the appropriate header of the data row that should supply the feature with information. The flow is run and outputs a more advanced report

 

So far I can enable containers with checkboxes, with detours added this can function as a proper feature toggles. Sadly, I have not been able to create a working flow with dynamic column selection as input for the toggled features. Is this even possible? 

Alteryx Certified Partner
Atom

I have followed the link and it looks like it should completely solve my problems, however, when implementing it I seem to hit some strange behavior. 

 

When chaining the apps and writing a yxdb file for the next flow to read, it seems that the second flow does not use the new data. I have a list box reading the xydb as input, but this does not update the list when I run it as analytics app. The strange thing is, when I remove and create the file input, the contents does seem to be updates in the app. From the text in your link I thought it would simply work, but in the downloadable example it seems the same error is present. 

 

Running the second step given another interface than the running it chained from the first. This is not the behavior I expected, is this a bug or intended? 

 

 

Atom

I fixed it by applying this solution