Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Dynamic Input Not Pulling All Excel File Columns In Correctly


I have a workflow which has numerous inputs, runs them through various tools to format/rename/select fields needed for final output and then brings them all together with a union tool.  Originally, I used the standard input tool for all files and it works fine.  However, I found that there are a few files that may not exist in some months (this will be a monthly process).  So I'm trying to use the dynamic input tool for those so that it won't cause an error when the file isn't there.  I'm testing it out and for some reason, the first 8 columns are coming in as all nulls while the last few columns are completely missing.  When I look at my input template it appears to be fine.


Any reason this could be happening and is there a fix?


Here's a view of the workflow with the dynamic input tool parameters:




The "FullPath" field comes from the directory tool, selecting the file I'm trying to read (based on a naming convention) with the tab name (|||Mapping) added to the FullPath via the formula tool.  The headers are not on the first row, so I use a sample tool and dynamic rename to clean that up after the dynamic input grabs the data.  Seems to make sense, but when I run it, I see this coming out of the dynamic input (just showing the first 12 columns):



The Excel file looks like this (same format for file defined by FullPath and template):



Why is everything before column "I" coming in as null?  Also, it doesn't bring in the columns after "AI" at all even though there is data in AK and AL.



Thank you.


Sorry, I believe I solved my own problem but I figure I'll leave it out here in case anyone else encounters the same issue.  It turns out the Excel file has a named range called "Mapping" as well as the sheet with the same name.  So it was reading the named range instead of the whole sheet when I specified "|||Mapping" in the FullPath field.


To force it to read the sheet instead of the named range, you have to add a dollar sign.  so "|||Mapping$" will work in this case.




Hey!  This answer helped me today.  Thanks!