Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Double data type is rendered as text for few values in few columns in alteryx worflow

Highlighted
7 - Meteor

I have columns with double datatype and when rendered into .xlsx output file a few numbers are dispalayed as text.( small green triangle at the left top corner of the cell)

 

Whats the issue.How can this be corrected.

Highlighted
Alteryx
Alteryx

@PoojaSingh88  can you share the workflow for us?

7 - Meteor

its a large workflow and cant be shared due to data confidentiality rules.

 

However I can share few examples of what's happening

when I check the browse for the column 1 which is configured as a double - I can see the value as per below

-917730

 

when I use the table tool -> Layout -> render tool to output this in .xlsx I see the output as -917,730 but as a text format a green triangle on left top corner of the cell.

 

Also to note I have read these via a binary input file and am writing it to xlsx.

 

 

Highlighted
Alteryx
Alteryx

The Render tool effectively creates the table as a blob type this is why the formatting defaults to Text (V_WString).

 

Double does not support Blobs.

 

Is there a way you can output the columns directly using the Output tool?

Highlighted
7 - Meteor

I need to use render tool as formatting is required in the output report ...what other data type can I use that would support the number format in the render tool ?

Highlighted
Alteryx
Alteryx

@PoojaSingh88 

 

What does the number represent in your data?

 

I came across this post

 

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Output-currency-in-Excel-as-number-not...

 

Here the output appears in Excel as a Custom/Currency/Special format.

 

Maybe this will help you in some way?

Highlighted
7 - Meteor

Hi ,

 

I still am facing issues.

 

Now I am reading the input files in .xlsx format. processing data all in double datatype and outputting to a .xlsx file using the render tool.

 

A few negative large numbers are being written as text and not numbers. This is causing issues to validate.

 

Any help would be appreciated.

Ex: attachd

Labels