community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Different Format in First Field causes Blanks on Input

Meteor

I'm inputting a file using the sample tool to skip to the correct record, however when the format changes from Year to Year/Qtr, the result shows 'null'

 

I've used a select tool before the sample tool to set the first column to a V_string 19 char, but it still comes in 'null.'

 

Any Ideas?

 

Capture.JPGCaptureoutput.JPGselect tool.JPG

Highlighted
ACE Emeritus
ACE Emeritus

Its not the select or the sample that is having trouble with it.  Its the initial datatype that is problematic.  Alteryx is told by Excel that this column is a numeric.  You would have to go back into the excel and correctly make this column a text otherwise it is going to convert these always to NULL.

Meteor

Thanks for the idea, however it didn't change anything. 

Meteor

There's something wonky about the input file, you're right.  I copied that page onto a different workbook and saved.  The input ran correctly.  Thanks for the direction!

Alteryx Certified Partner
Alteryx Certified Partner

@cwilcoxmtn,

 

I can't get the "bad" results to happen.  Here is my configuration of the input tool:

Capture.PNG

 

In option #7 I tell the (version 11) input tool to start on line 70.  I also told it that the data (not the fieldname) starts there.

 

It is Friday and maybe I'm already out the door, but have you tried something like this?

 

Cheers,

Mark

 

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Meteor

Thanks Mark. It isn't Alteryx, there's something about the input file I can't put my finger on.  I've converted the field to a text as suggested, same result. When I take the whole tab and paste it into a new workbook, it inputs correctly.  I'll have to explore on the excel side more. 

Meteor

It was delivered as an excel 97-2003 workbook.  When I resaved as Excel workbook.  It worked perfectly!  So obvious.

Labels