community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Desktop Scheduler not working

Asteroid

Hi,

 

I did a trial of Desktop Scheduler and everything worked fine.

 

I now have a paid License Key, and some workflows return errors when run by the Scheduler.

 

The same workflows worked fine last week with the trial and they all run successfully if I manually run them.

 

So far, it seems like the following tools are causing problems:

  • Input data from a database (screenshot 1)
  • Publish to Tableau Server (screenshot 2)

Since finishing the trial last week, I have upgraded to Alteryx 2019.1, however this morning I tried reinstalling 2018.4 and the same thing happened.

 

Any ideas?

 

Alteryx Scheduler_ODBC input.JPGAlteryx Scheduler_publish to TS.JPG

 

Highlighted
Pulsar

Have you tried re-installing or re-configuring the ODBC driver and PublishTo TableauServer macro?

 

Do these workflows run successfully without the scheduler?

 

It could also be related to UNC file paths, since the scheduler can't interpret mapped drives, so if the PublishToTableaServer macro lives on a mapped drive, for instance, the scheduler won't be able to read it. For this reason I always use absolute paths in any workflow that I want to run through the scheduler, i.e. \\servername\foldername\etc.

Asteroid

@DavidP Thanks for your comments

 

I resolved this with help from Alteryx Support.

 

For connecting to a database, I had to set up the data source with a system DSN in ODBC manager (not in Alteryx)

 

For Publish to Tableau Server, the macro was installed at "C:\Users\<Username>\AppData\Roaming\Alteryx\Tools" but Scheduler requires it to be installed at "C:\ProgramData\Alteryx\Tools" (the tools folder didn't exist so I created it).

 

I have no idea why I didn't have these issues when I trialled Scheduler but the above fixed the errors.

Asteroid

I stumbled across what appears to be the real issue...

 

When I trialled Scheduler, I entered my details on the 'Run As' screen in System Settings.

 

When I started using Scheduler again, I didn’t re-enter my details. I don’t know if they disappeared during the upgrade to 2019.1, but once I re-entered them, the errors I was having above no longer appeared

Labels