Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Check out our powerful new search update! You can read more here. Please let us know if you have any feedback by creating a topic here.

Desktop Scheduler Unable to Translate Alias

Highlighted

Hello Everyone,

We purchased Alteryx Designer and the desktop scheduler for our company.  I am the only user (license administrator too), and downloaded Alteryx Designer (Admin Version) from the license manager.  I am able to run my workflows on my computer (locally) without any errors.  I try to schedule jobs using the desktop scheduler (Options -> Schedule Workflow -> My Computer -> and Running a copy of the workflow stored in the Scheduler DB or Running the workflow from its original location on Disc), and it fails in less than 5 second with the error: "Unable to translate alias aka: (Connection Name||Connection String) for the input data and output data".  I am moving data from oracle to SQL server, and from Amazon Web Services to SQL Server 

 

I read other threads that individuals have this issue when trying to publish a workflow, but we did not purchase the server, so I am not publishing the wf.  There were some other threads that also suggested that the connections have to be shared, and not just user connections.  I should be able to do this by using the Advanced settings (Options -> Advanced Options -> System Settings), but everything is grey, and I am unable to click anywhere or make any modifications. I have attached images if it helps any.

 

Thank you for the assistance!!

Highlighted
Alteryx Certified Partner
Alteryx Certified Partner

For workflows that are shared or scheduled, I recommend configuring your Oracle and SQL Server connections with an ODBC connection (Input Tool > Other Databases > ODBC...). Just make sure the ODBC Manager on the computers involved have the same DSN connections configured.

 

Another suggestion when scheduling workflows is to make sure the Alteryx engine has the necessary credentials for the workflow to execute properly. You can specify the user credentials in System Settings > Worker > Run As...

I just got off a call with Alteryx support and figured out part of the issue:

Due to my lack of knowledge on User DSN settings and System DSN settings, I set the connections as User DSN's.  We went the route of user DSN's first, and we would have used the Advanced Options-> System Settings -> Worker -> Run as, but I am unable to get this window to work as shown in the images linked to the original post; however, we modified the RuntimeSettings.XML in the location "C:\ProgramData\Alteryx".  After the </Engine> we added the following code in (if you do not know your domain, open command prompt and type "whoami" and it will be the information before your login):

 

    <Worker>
        <ExecuteDomain>YourDomainHere</ExecuteDomain>
        <ExecutePasswordEncrypted>YourPasswordHere</ExecutePasswordEncrypted>
        <ExecuteUserName>YourUserNameHere</ExecuteUserName>
    </Worker>

 

We tested the scheduler, and it worked under the User DSN.  I am now working to create System DSN's so I do not have to store my username and password (since we constantly change passwords). 

 

I am still unable to interact with the advanced settings, but once a solution is found, I will let everyone know.

 

Thank you for the assistance Charlie and MarqueeCrew!

Labels