community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More
SOLVED

Designer x64 Error

Meteor

I am also facing the same issue and the issue is quite intermittent. 

 

For example, I have to run the workflow for three to four times and it gives the error for all the times and then suddenly on the fifth time it starts. I think this issue is in 11.5, as I have never faced the issue in 10.3. 

Atom

Sophia:

 

I'm getting this error message intermittently. I'm using ver 11.5.1.31573, 64 bit, windows 10. I'm using the data input tool and inputting both .xml and .json files.

 

What happens is that the connection works for a period of time. I'll run my work flow anywhere from 5 to 15 times as I'm working it up. Then I get the error message. Twice I closed out of alteryx and reopened it and didn't get the error. However this happened a 3d time and closing and then reopening the program didn't work.

 

The response that's listed as the solution doesn't provide a solution that can be used by others. It just says the poster's I.T. department did something to white list the program.

 

Any idea of what could be the real cause? Any idea of a solution?

 

Thanks, BES

Meteor
Please press F5 before you run. This will solve the problem.

Best Regards
Yogesh Agarwal
Atom

Yogesh:

Thanks, what exactly is hitting F5 supposed to do? What's the underlying problem is supposed to fix?

 

(I tried your suggestion and it didn't appear to do anything.)

Highlighted
Meteor
F5 refreshes the workflow and for me it has resolved the workflow. I just have to hit F5 and then run the workflow. It worked for me.

Best Regards
Yogesh Agarwal
Bolide

I'm getting this error too, but only with the latest version of Alteryx 11.7, I hit F5 doesn't help sometimes I have to do it multiple times. And this is just with text inputs still doing it so it's probably the whitelist issue as noted above but it's weird that all of sudden this is happening so either it was a change internally at my company or something with the latest version of Alteryx?

 

 

Atom

In Local Security Policy -> Software Restriction Policies -> Additional Rules -> New Path Rule, I have added path folder path, which contains bin folder, but still I get the same error.

Can someone please confirm how to resolve this error. Is there any log file, which can tell me exact process, which is causing this issue ? 

 

 

Thank you in advance !! 

 

Regards

 

Digant

Bolide

I did not actually see a solution so I am offering this

 

“Start: ConnectNamedPipe” Errors that occur when attempting to run the flow...at very beginning are in my experience due to security software like McAfee ATP (active threat protection).  Bear in mind Alteryx is a "Load & Go" type of high level programming language that when you press "play" it runs a series of programs and snippets to transform your GUI workflow into a machine language executable form.  These newer types of protection software, even when in "Observe" mode, will intercept and analyze all that activity to score it as a risk or not.  This can at times cause delays in the interconnected events, thus ConnectNamedPipe error, basically a thread between 2 or more activities time out.

 

Another error we saw frequently before sorting this out is "Root Element Missing".  this usually occurs when you open a flow and click on an input or dynamic input that has SQL.  The issue here is the delay we are experiencing cause the initial DB query to get Table info failed, probably for timeout, and so you get a Root Element Missing error.

 

Be aware that errors “DataWrap2_ConnectNamedPipe after 11000 milliseconds” are a different issue, this seems to be a connectivity timeout, to NAS storage or some other data appliance.

 

The idea of a white list is to identify programs, files and or folders to exclude from the security program's process.  

 

The attached pics are what we implemented with success for both Admin and non-Admin installs

 

 
Meteor

thank you same issue here connecting to a .yxdb; I'll follow up with IT to see about getting the app whitelisted as suggested by Alteryx support.

 

 

Meteor

I tried this method and voila, it works!  

Labels