community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
SOLVED

Designer Workflow Dependencies Edits Cannot be Saved

Alteryx Partner

I initially had an error " Runner Tool: Failed to run external program "SupportingExes\AlteryxRunner.exe": The system cannot find the file specified." when trying to run CrewMacros Runner Tool. Then I looked at the workflow dependencies and figured out that the path for installing the runner tool is not correct. So I went to edit and updated the correct one and clicked OK. However the updates I made cannot be saved in the tool. The same error keeps popping up when trying to rerun the workflow. And when getting back to check the workflow dependencies, the updates were not saved.

 

Can anyone help on this please?

 

Many thanks,

Zoey

Alteryx Certified Partner

Hi @ZoeyL1GL 

 

Are you using relative paths? 

At least if you post screenshots of the errors and how workflow dependencies are configured we could have a better picture of what you're going through.

 

Cheers,

Alteryx Partner

Hi @Thableaus ,

 

Thanks for replying. No I had used absolute paths. Please find below the screenshot.

Capture.PNGprior editing the path, when testing, the directory doesnt existCapture.PNGafter updating the path by removing the runner tool at the back, testing to see the path works. Then saved the updated path by clicked OK. Closed the window after clicking OK.Capture.PNGRan the workflow and the runner tool still throwing out error. When getting back to check the workflow dependencies window, the edited path went back to the old one.

Highlighted
Alteryx Certified Partner

Hi @ZoeyL1GL 

 

Am I correct by saying you're putting the macro in a ZIP folder? (Temp1_Macros.zip)

 

Could you put it in a regular folder? Just to test it.

 

Cheers,

Alteryx Partner

Hi @Thableaus , 

 

Thanks for spotting that. That is a zip file, but having .zip in the folder name as I didnt extract the macros before installing.

 

This is where things went wrong actually, I uninstalled the Crew macros and reinstalled after extracted the macros to a normal folder. Now the dependencies work fine in the Runner Tool.

 

Many thanks! Will mark your reply as a solution.

 

Zoey

Labels