ALTERYX INSPIRE | Join us this May for for a multi-day virtual analytics + data science experience like no other! Register Now

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Data won't flow through any tools

11 - Bolide

Last week on Designer 2019.4 things randomly stopped working after a computer reboot. Data pulled fine from any source, but if I add a select tool or a formula tool, no fields are showing to allow me to configure those tool (yes, I ran the workflow!). Any tools placed before the input tool work fine, like if I am using select or formula prior to a dynamic input. By the end of last week, after exploring every setting and searching the community for solutions, I did a complete uninstall and new install of the latest Designer version, and things worked fine for a day. This morning issue started occurring again!! Please see the attached screen shot from last week showing the empty configuration pane for the select tool and a formula tool where I attempted to use columns. The second screen shot is from today. When the select tool started causing me issues, I created a different branch of the workflow. After the second time I ran it with this work around, data made it through the select tool, but got lost on the branch from the input to the join.

Other troubleshooting points:

I have sent my workflow to another on my team and they haven't encountered any error

Someone sent their workflow to me and I had the same error

Another co-worker had the same error at the same time, but the upgrade to the latest version has fixed it for him (as of now)


Any help is appreciated!!

17 - Castor
17 - Castor

Hi @SGolnik 


Let's try a couple things:

- Press F5 to refresh the workflow, do the fields appear then?

- If you run the workflow, does it run successfully? are the fields populated after?

11 - Bolide

I did the F5 and the fields are now showing in all of the select tools, but when I run it both the input tool and the select tools show "No data available" (like it does when you are developing and before you run it) in the results window and the data will only flow out to a browse tool...even if the browse tool is after one of the tools that have no data on output. The workflow does run successfully still with no errors or any warnings related to those problem tools.


This is the wildest thing I've ever seen!!!