community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Data Cleansing tool suddenly stopped working. Invalid Path: "Cleanse.yxmc"

Hi all,

 

Hoping someone can help me out here as I have suddenly found that in all my workflows I am receiving errors as the Data Cleansing Tool has suddenly stopped working with the error message Data Cleansing "Invalid Path: Cleanse.yxmc".

 

Even if I create a brand new workflow with just an input tool and data cleansing I still get the error.

 

I have even uninstalled and reinstalled Alteryx and it still comes up with the error ! :(

 

Alteryx Invalid Path error.PNG

 

How can I see what Path is being used for a tool ?

 

Any help is greatly appreciated.

 

Matt

Alteryx
Alteryx

That is definitely odd, as if the file was missing, then normally the icon would not even show up. The Path for that Macro is

 

<Alteryx Install Folder>\bin\RuntimeData\Macros\Cleanse.yxmc

Has there been any change in versions or Alteryx Install Location recently?

 

Try putting the attached Macro (Back up anything before overwriting) into that folder and see if that corrects anything. Otherwise, reach out to support@alteryx.com

 

Kane

 

Hi Kane, many thanks for responding. I replaced the macro but no joy so I have emailed Alteryx Support.

 

I will post the answer and fix if I get one back into this thread. 

 

Matt

For anyone that experiences this I thought I would close off the loop as support@alteryx.com were able to find a fix.

 

The fix they suggested which worked was as follows:

---------------------

Hi Matthew,

We have seen this when there are possibly duplicate versions that were installed or something was corrupted with the tool. Could you try uninstalling one more time, and then removing (after backing up by making a copy) the following folders and their contents:

%PROGRAMFILES%\Alteryx 
%PROGRAMFILES(x86)%\Alteryx 
%PROGRAMDATA%\Alteryx 
%LOCALAPPDATA%\Alteryx 
%APPDATA%\Alteryx

Then, you should be clear to reinstall.

-----------------------------------------------

 

I now have the Data Cleansing tool back :) Phew.....

Highlighted

+1 this worked for me. 

 

I was getting errors on Data Cleansing and other standard-tool macros.  I have Alteryx installed on an AWS Workspace as my primary set up, but I have a copy locally as well.  This messed up my Workspace install for like 3 days before I found this thread.  Luckily I had a back up but it was so frustrating the past couple of days, thank you so much for posting the solution!

Labels