Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

DB2 database connection


Can someone please explain how to use the ODBC connections to connect to a DB2 database?


I have all the drivers installed and all required permissions, but it still doesn't pull the database correctly (empty Db; 0 tables).


PS: I must say, I assumed Alteryx would be able to connect to DB2 directly and purchased the tool, but I've had to run around in circles to bridge this gap. Please fix this.


Hi @gana1992


If you are using a User or System DSN for the connection, are you pointing to the correct database name in the ODBC DSN settings? Which driver are you using? The supported versions are stated in the help documentation.









Hi JakeS, Thanks for the reply. 


I did partially solve that problem, but there seems to be an extended problem.


I need to connect to 2 different DB2 Databases (say A & B), structured similarly. I'm currently using a System DSN for the connection and it connects only to a single database (Connects only to A, B doesn't connect irrespective if A is / isn't connected) . I use the same method for B, but it doesn't work. To be more specific, I can see the correct table in the input/import option, but when I run it, I see a "no columns returned".


Please help.


Hi @gana1992


When you try to connect to Database "B", are you using the same System DSN as Database "A" and just changing the database name or are you creating an entirely new DSN? It's possible that there are different/ additional CLI parameters that would need to be set under the advanced settings portion of the driver for the other database to work correctly. Also, do you know that you have the same permissions for both databases?






No, I use a different System DSN for "B", and permission on that is the same as 'A'. I've connected to the 2 databases on Tableau and DB Visualizer before so I'm sure I have the correct permissions. 


I'm surprised I can see the table, but it says it has no columns to return. Please advise.


Update: I was able to solve this by doing the following -

  • Deleting all previous connections
  • Updating drivers
  • Using SQL by variable names (in the SQL editor) instead of physically selecting the table.

Thank you for the help.