community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE
SOLVED

Curl Proxy Https Request

Alteryx Certified Partner
Alteryx Certified Partner

Oh how I struggled....

 

Run Command

Command

<Path>\curl.exe

Command Arguments

-k <https://<web URL string>  --proxy <proxy address>:<port> --proxy-user <userid>:<password>@<your-proxy-ip-address Port> -o "%temp%\temp_read.csv"

Where %temp%\temp_read.csv puts the data to where you'll read from:

Input

%temp%\temp_read.csv


Should this have been easy?  I hope that it is helpful for others.

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Meteoroid

MarqueeCrew,

 

I am also using cURL for an API project using Digest authentication. However the version of cURL installed with Alteryx doesn't support HTTPS - I'm on 11.5. Can you confirm if your version of cURL (C:\Program Files\Alteryx\bin\RuntimeData\Analytic_Apps) supports HTTPS, or did you download a later version to get this to work? Just concerned that I will have to rollout an updated version of cURL to any Alteryx desktop users who want to run this workflow. 

Alteryx Certified Partner
Alteryx Certified Partner

I did download another version: 7.56.1 -win64-mingw

 

:)

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Pulsar
Pulsar

Hi @MarqueeCrew!

 

I've been struggling like crazy the past couple weeks with this.  I just can't seem to get it.  Our IT firewall necessitates the use of cURL.  I had a macro built years ago by our old rep that used the syntax:   

 

-proxy-ntlm -x proxy.http://<UserName:Password>@###.##.###.###:80 http://earthquake.usgs.gov/earthquakes/catalogs/eqs7day-M1.txt -o "%temp%out.txt"

 

It worked fine until everything starting going to HTTPS.  Now it doesn't work at all.

 

I downloaded this curl version to C:\curl (I created a new folder for that).

 

7.56.1 - SSL enabled SSH enabled 
URL: https://bintray.com/artifact/downlo...-win64-mingw.7z 
Provided by: Viktor Szakáts

 

And tried your syntax (

-k <https://<web URL string>  --proxy <proxy address>:<port> --proxy-user <userid>:<password>@<your-proxy-ip-address Port> -o "%temp%\temp_read.csv"

but I keep getting error code 1.  Can you clarify that you mean by the part after the url:

--proxy <proxy address>:<port>

Is that the same as 

<your-proxy-ip-address Port>

?

 

Any help would be greatly appreciated.  I've been puling out my non-existent hair.

Alteryx Certified Partner
Alteryx Certified Partner
-k <https://<web URL string>  --proxy <proxy address>:<port> --proxy-user <userid>:<password> -o "%temp%\temp_read.csv"

@mbarone

 

Try above.

 

Cheers,

Mark

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and reboot. Order shall return.
Pulsar
Pulsar

That did the trick!!!!!!!!!!!!!!!!!


Thanks Mark - I owe you a beer at the next Inspire (even though they're included LOL)!!  Sometimes it's all in the syntax!

Pulsar
Pulsar

Your response can be marked as another solution, but I'm unable to mark it as such.  I think just the original poster can, which would be you - so I think that deserves another accepted solution!

Labels