community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Announcement | We'll be doing maintenance between 9am-11am MT on Saturday, January 25th, which may impact your experience. Thanks for your patience as we work on improving the community!

Conversion error on variable or parameter *N.

Asteroid

Hello Alteryx Community!!

 

I have a workflow in designer on a Windows Server 2012 R2.  Within the workflow, I am trying to pass a parameter via user input from a text box tool to a Dynamic Select Tool that has a SQL statement querying DB2.  As an example, a typical entry would be the number 1.

 

When the user types a 1, that value is used in the query.  However, I keep getting an error "Error: Dynamic Input (7): Error SQLExecute: [IBM][System i Access ODBC Driver][DB2 for i5/OS]SQL0302 - Conversion error on variable or parameter *N."

 

I noticed that the data type for the field in the query is a decimal.  I tried using a Select tool to make the parameter value from my text input a fixed decimal, but I am still getting the error.  I'm not sure what else to try.

 

 

N parameter.PNG

Alteryx
Alteryx

Can you please post a picture of the configuration pane of the Update Action? (Click on the Action Update icon and screenshot the configuration panel on the left-hand portion of the Designer window)

Asteroid

N parameter2.PNG

Alteryx
Alteryx

Can you also send the configuration for the Dynamic Input tool, including the pop-out window for how you are applying those changes to the Dynamic Input. Should look like this;

 

Or if you can attach the workflow without there being data sensitivity issues, that would be even better and cut down the back and forth!

 

Cheers!

Zak

 

image.png

Asteroid

I can't share the workflow because of (as you said) data sensitivity.  Here are some more screenshots:

 

N parameter3.PNG

 

 

N parameter4.PNG

 

 

 

N parameter5.PNG

Alteryx
Alteryx

On your Update WHERE Clause - you are saying that the field is an integer but your select tool has it configured to be a Float - the conversion error is likely arising from that.

 

If the field is FLOAT in your underlying DB, then change the WHERE Clause update to reflect the data element to be Float. If it is integer in your underlying DB, modify the select tool to cast it to an Int64.

 

Let me know if this works!

Asteroid

In the underlying DB, the field is showing as a decimal with a size of 3.  I'm still not having any luck after trying your suggestion :(

 

 

Comet

If the field in the database is a numeric type, have you tried writing the SQL without quoting the value? I think numeric values have to be unquoted in the conditions.

 

e.g. 

 

CUPUCA.UCMSG <> UCMSG3

 

instead of

 

CUPUCA.UCMSG <> 'UCMSG3'

Asteroid

Ah, I was wondering about that.  I'll give it a go.

Labels