community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Cant see fields after running a macro

Asteroid

Hi,

 

I have an XML file that I have created a little macro for - this extracts the data from the XML to use in my workflows.  I have a problem though - I can run the macro and see the results in the browse tool but if I add another tool, such as a Unique tool (Since I know I have a couple of duplicates in the file, somewhere!) - I cant see the fields to select which should be unique - see the screenshot below - is it something wrong with my macro/workflow or is this a bug?  The browse at the output of the Macro tool shows the data as I expect it should but I cant post a screenshot of the data!UniqueTool.jpg

 

 

Bolide
Bolide

Hi @craigja,

 

I've tried replicating your setup, but based on my simple example all fields are visible both before and after running the workflow.

 

My suspicion is that the inside of your macro may be more complex and thus Alteryx is not able to determine what fields will be available after it runs, however you're saying that even after running your workflow the Browse tool is fine, however the Unique one is not. 

 

Couple of ideas:

 

- try adding a Select tool after the macro, is it not seeing any fields as well, if it does, try adding the Unique after Select

- try closing Alteryx and open the workflow with a fresh service in your operating system (quite possibly this is some funny overhang, memory issue)

- try adding Ensure Fields before Macro Output inside your macro (this is available from Crew Macro Pack: http://www.chaosreignswithin.com/p/macros.html) this may help to enforce visibility of fields 

 

XML is a more involved data structure, where you target certain nodes and navigate potentially complex tree of nested parent/child relationships - my suspicion is that this complexity/ambiguity is giving a hard time to evaluate what fields may come from your macro. 

 

Thanks,

Rafal

 

#Excuse me, do you speak Alteryx?

Asteroid

Hi,

 

Have tried suggestions 1 and 2 but they dont work - If I add a tool after the output and look at the input to that tool I can see data going in. I will go have a look a the team macros and see if that helps

Asteroid

I cant seem to download the team macro's - I think our company firewall might be blocking them

Labels