Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
SOLVED

Cannot find macro?

JohnMaty
9 - Comet

I just upgraded ALteryx and now my scheduled jobs are failing with some flavor of this error.

 

Error: Tool #15: Cannot find macro "CReW_ParallelBlockUntilDone.yxmc".

 

How can I tell where I need to put this macro?

 

8 REPLIES 8
SeanAdams
17 - Castor
17 - Castor

+ @AdamR who built the CREW Macros.

AdamR
Alteryx
Alteryx

Have you tried re-running the CReW macro installer?

Adam Riley
Principal Software Engineer
Tech Lead Core Engines, Alteryx
JohnMaty
9 - Comet

I had a few things going on.  First I installed the new version of Alteryx (which is great).  This appeared to break the current connection to the CReW Macros.  Then I downloaded the new CreW macros and installed them but placed in a different location than my old macros.  That caused a conflict between current macros in my workflows and new macros available. 

 

Long story short, I needed to go into user settings, remove the recursive locations of my macros and have the macros location point to the correct/new location.

 

I am good to go now.

 

 

Machingwa
7 - Meteor

I am using a conditional runner in my workflow and it runs well on my desktop but when i try to save it on the server it is giving me this error.

 

maccro error.PNG

 

 

 

 

Do you have screen shots of how you fixed you issue.

 

Thank you

 

 

KJennings
8 - Asteroid

Our site is seeing this error as well, using version 11.3.

I stepped through our server settings, and do not see how recursive (??) is even related to the macros... I see no reference to macros at all.

 

Would it be possible to see how your solution was done?

 

Regards.

JDelgado
8 - Asteroid

I am having the same problem - I am using the "Publish to Tableau Server" macro.

 

The macro installed to my user\roaming folder, but I also copied it to a network location where I have also placed other resources used by the workflow.

 

The User Settings\Macros tab did not have any entries in it - I tried adding a path to the "roaming" folder location and also one for the network drive location of the macro. Neither setting made any difference.

 

Can someone provide some additional guidance on how to resolve this? (I'm saving the workflow to our Gallery - I have no issues saving\running the workflow locally)

 

Thanks!

 

Unable to save to Gallery.jpg

JDelgado
8 - Asteroid

Same issue trying to use the Alteryx WDC for Tableau tool, please help!

 

Unable to save to Gallery 2.jpg

JDelgado
8 - Asteroid

I had similar problems tryg to use the Alteryx Web Data Connector tool. I was able to resolve that problem by selecting "Manage workflow assets" in the Workflow Options when saving to the Gallery. But when I tried the same solution for the Publish To Tableau Server Tool - I still get the "Cannot Find Macro" error, but only for the sub-macros...?

I select all the workflow assets, but when I save to the Gallery, the "sub-macros" cannot be foundI select all the workflow assets, but when I save to the Gallery, the "sub-macros" cannot be found

 

And then when I go back to the designer, now my Publish to Tableau Server tool is broken:

 

After save fails, when I go back to the designer, the Tableau tool is now broken.After save fails, when I go back to the designer, the Tableau tool is now broken.

 

The only way to fix it is to delete the tool and re-add it.

Labels