Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More
We will be upgrading the Gallery to our 2019.4 release this Saturday, December 7th beginning at 9:00am MT. We expect the outage to take last approx. 2.5 hours.

Cannot find macro in local machine Scheduler (desktop automation)


Hi all


I work with Alteryx 2018.3 and desktop automation, with scheduler running on my local machine.


When I try to schedule a workflow with a macro, it always crashes with "cannot find the macro".


I've tried to

- put it in the same folder as my workflow => same error message

- export my workflow as a package, with the macro => other error, not finding my input files (while I'm using a Directory tool, with UNC path).


Does anyone can help? Thank you!


Hi Anne-Lise,


A few questions:


1. Is the macro in a folder only accessible by your user? If so, have you set a 'Run As' user in the scheduler?

2. Have you tried to schedule from original location on disk?






hi Amelia!


Fist of all thank you for your answer ;-)


I think I have the explanation, it is not linked to the macro, but with the drive where the macro is stored... It is a Novell client, it works perfectly well via the Designer, but the scheduler cannot access the drive, even with UNC.


Our Network guys will look at it tomorrow morning, hopefully we will find a solution.


Kind regards,




Hi @Anne-Lise,


Adding a Run-As user for the scheduler could likely resolve this issue. To add a Run-As user:


1. Go to Options > Advanced Options > System Settings

2. Click 'Next' until you get to the 'Worker - Run As' section

3. Add you domain (AD domain), user and password - these will be your Windows log in. 


Test your scheduler again and see if it works :) 




Hi Amelia,


It is already done and it is not working. I can access other network drives, but not all of them, the one based on novell clients are still unavailable :-(


Hi @Anne-Lise,


Is the Novell client network drive mapped on your machine? Do you know how they authenticate?






Hi, @AmeliaG.

Your tips were extremely useful to me!

Thanks a lot!