community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

CReW Macros - The external program "SupportingExes\AlteryxRunner.exe" returned an error

Alteryx
Alteryx

The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741515

 

Creating a new thread for this to see if we can get anywhere with working out what it could be.

 

Thanks @ben_broom @PoweredByWindows7 @userfriendly1 for reporting this issue.

 

Has anyone had any success in getting round it?

 

And then some questions:

 

1.  What version of the Crew Macros are you using?

2.  What version of Alteryx?

3.  What version of Windows?

4.  32-bit or 64-bit Alteryx?

5.  Have the runner macros ever worked on the affected machines?

 

I'm guessing that it is a missing dependency given that @PoweredByWindows7 gets it only on a VM, but not sure what it could be yet.

Adam Riley
Principal Software Engineer
Tech Lead Core Engines, Alteryx
Meteoroid

Hey @adamr, thanks for the quick response.

 

We thought about bypassing the JIT Debugger Exception thrown by Windows Server 2012 R2 by deleting the registry keys for the JIT Debugger, however, we didn't go through with this because it sounds like a bad idea. 

 

So, as of now, it is blocking our production Alteryx 11.0 servers ability to utilize the Conditional Runner and other Crew Macros that rely on AlteryxRunner.exe.

 

1.  What version of the Crew Macros are you using? Crew Macro Pack - 2016 Q2 Release

2.  What version of Alteryx? Server 11.0

3.  What version of Windows? Windows Server 2012 R2

4.  32-bit or 64-bit Alteryx? 64

5.  Have the runner macros ever worked on the affected machines? No

 

Let me know if you need more info!

Alteryx
Alteryx

I'm afraid I am struggling to reproduce this.

 

I installed Windows Server 2012 R2 on a VM and it works OK for me.

 

I'll try and see if I can add any more debugging info to the AlteryxRunner.exe that might help with diagnosis.

Adam Riley
Principal Software Engineer
Tech Lead Core Engines, Alteryx
Meteoroid
Thanks for looking into this Adam.

Ill also try to check on our server to see if something is configured incorrectly on the VM.
Asteroid

I am also facing similar issue. Please let me know if you have solution.

 

The external program "Alteryx Runner.exe" returned an error code: -1

I'm also having a similar issue. My first runner properly executes the first workflow, however, it stops and does not run the next workflow due to "errors." There are no red errors, but there are some conversion errors (that don't corrupt the file). I cannot figure out how to get this to properly run and any advice would be greatly appreciated.

 

Thanks!

Kaileen

I am also having a similar problem. I have a list of workflows scheduled on the server, using the list-runner. I am currently using Version 1.0 of the List-runner. Further, I am also publishing to Tableau Server using the Publish to Tableau Server macro. 

 

The weird thing is that it worked some weeks ago, but now it seems as a problem arises. I keep getting an error in the output-log similar to yours:

 

Designer x64 Tool #4: Tool #3: Iteration #1: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1073741818

Designer x64 Tool #4: Tool #3: The output connection "Logs" was not valid

 

Do people have any idea about the reason for this?

 

Alteryx Certified Partner

Hello All,

 

I'm not sure if this helps but I encountered a similar error on a Windows Server box when I was using a scheduled workflow with a different "Run As" user than who installed the CReW Macros. Once I gave the "Run As" user access to the drive with the CReW Macros I avoided the error.

 

-Phil

I hate it when I have to admit a user error,but I will for the greater good of the community.

 

I was getting this error because I had ordered my filepath incorrectly in the formula.  Check to make sure your path is in order.

Alteryx Partner

Just found this. The solution for me was to include the location of the AlteryxEngine.exe in the path of system variables on the computer. Basically the error message is saying I can't find the Alteryx exe, and that it needs to be added to the variables on that windows maching

Labels