Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Bug: Input data tool connecting using POSTGRESQL but unable to fetch data: GEOMETRY No col

We have a workflow which is running fine in Alteryx 10.6 version (Connecting to Denodo using POSTGRESQL 9.03.04) however after the upgrade I am getting the below error.


for testing I have created an Input data tool using POSTGRESQL to connect to Denodo data source. Connection was successful and able to see all the tables. When try to fetch the data I am getting the below error.


Error opening "SELECT oid fro pg_type where typname='geometry'": No Columns Returned


Please find the attached document and mapping with the screenshots.

Inactive User
Not applicable

Have you confirmed after the upgrade the driver remained the same? I would check that as the upgrade may have changed the underlying driver which could be causing you issues.

I too have the similar issue after the upgrade I am getting the same error. I have used POSTGRESQL09.03.0400 and also 9.06.310 As mentioned in the Alteryx site and still getting the same error


Hello @ananthpeddi,


Are you attempting to connect to a Denodo DB? Denodo is not a supported data source with Alteryx, but if you feel like this would be a valuable feature in future releases feel free to post this to our ideas page:

Hoss Carroll
Customer Support Engineer