community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

Browse not showing Data Profile (Profiling 0%)

Alteryx Partner

I'm using Alteryx Designer v2019.1.4.57073 on a Mac running VMware with a Windows 7 host.

 

When I connect to input data (ex. TutorialData.yxdb) and add a browse tool, I'm unable to see the data profile. It returns "Profiling 0%".

 

I have also confirmed that the option for "Collect and display data profile information" is checked under "User Settings"

 

I have restarted Alteryx and increased RAM from 2gb/4gb/8gb on the VM with no difference in behavior.

 

Thanks,

Ryan

Alteryx
Alteryx

Hi there

 

This looks like a memory leakage issue.  Do you cache a lot of your data when you run your workflows?

 

Silly as it sounds, have you also tried to reboot the VM and run the workflow?

 

This issue has been raised before and I will feed back internally.

Alteryx Partner

Hi RishiK,

 

Thanks for your reply.

 

I had read about the potential memory leak, so that's why I tried increasing the RAM in the VM from 2gb to 4gb to 8gb with no effect. Each time I changed the VM setting I had to completely shut it down and restart Alteryx.

 

This morning I was continuing a "Challenge" and put a browse on the canvas which actually showed the data profile. Surprised at this, I opened the TutorialData and attempted to view the data profile there. Thinking I might need to wait for it to render, I set my timer to 2 minutes and waited. No effect.

 

But this got me thinking, I opened up "Task Manager" and my CPU was throttled to 100% and staying redlined.

 

I decided to shut the VM down and increase my VM from using only 1 core, to using 2 cores. I rebooted, opened task manager, opened Alteryx and watched the CPU tach up and down.

 

When I then added the input to "TutorialData" and connected a browse to it, I was able to render the data profile fairly quickly. No more "Profiling: 0%"

 

Success. If you run into this issue in the future, increase your VM's cores.


Thanks,

Ryan

Labels