community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Upgrade Alteryx Designer in 10 Steps

Debating whether or not to upgrade to the latest version of Alteryx Designer?

LEARN MORE

Boosted Model Error

Alteryx
Alteryx

Hi @denizbeser,

 

This is actually unrelated to the issue in the thread, and the message does not provide enough message for debugging. The error is occurring in plotting, so the model was likely created. It would be beneficial to get the workflow where this error occurs. If you can attach to this thread that would be great, if you can't, then send me a private message to arrange getting the workflow to me.

 

Dan

Meteoroid

I was trying to reply under the boosted models sorry if i caused any inconvenience. I am attaching the workflow too 

 

Thanks for the help

Deniz

Alteryx
Alteryx

I did get the workflow, but not the data, which I will need. To do that, export the workflow as a yxzp file, which you can do by going to Options > Export Workflow. This will crate a zipped archive that contains both the Excel file and the Alteryx yxmd file.

Meteoroid

here is the exported workflow data

Alteryx
Alteryx

Sorry, but as the screen shot below indicates, the Boosed Model tool does not error on my computer when running the workflow you sent. Based on the screen shot in your original post, the issue was in creating a plot, so the model itself should actually have been created. It is possible to get additional information about the error on your computer by clicking on a blank area of the canvas, then clicking on the Runtime tab in the Workflow - Configuration window, and then in the group of five check boxes towards the bottom of the Runtime tab click on the "Show All Macro Messages" option. Once you have done this, run the workflow, and in the Output window a lot more diagnostic information will be provided. One other question, are you running Alteryx in a VM on a Mac?

 

Boosted_Working.png

 

Meteoroid

Thank you for the answer.

 

After I check the show all macros checkbox I am getting the same errors as before which is R.exe error on boosted model.  My team had an idea that it my be due to the antivirus program on our laptops since we are all working on our Work Computers. Could that be the reason why all our other models work but not Boosted?

 

Highlighted
Alteryx Certified Partner

@DrDan

 

I also am experiencing the 'The R.exe exit code (4294967295) indicated an error.' issue with 2018.1. The R tool outputs the data correctly, so it may seem like just an annoyance rather than a true error.

Unfortunately, my R tool is part of a batch macro inside of an iterative macro, and these macros stop when encountering an error, even those that aren't 'true' errors.

Do you know of a way to suppress the error? The gc() tip in this thread isn't helping in my case. Alternately, is there a way to force the macros to continue to run despite the non-error?

Alteryx
Alteryx

Unfortunately, no there isn't a way to suppress the error at this time. There are several things we have done to reduce the possible sources of that error. Specifically, we were encountering fairly often in the creation of the marginal effects plots. We found that pausing the R process for one-tenth of a second between plots addressed the issue (it provided enough time for the plot data to finish moving from R to Alteryx). That fix was part of the 2018.2 release. That might address the issue you are running into, but it may not. We are currently doing development in other areas which remove other potential causes of this "error", but that will be in a future release.

Atom

@rlangestr where do we put gc() exactly in R code?

Labels